MUltivalue Parameter

4 posts, 0 answers
  1. Dimi
    Dimi avatar
    2 posts
    Member since:
    Feb 2018

    Posted 18 Feb 2018 Link to this post

    Dear all i've read everything about multivalue articles but nothing works. I got attached error.For your information when i disable multivalue everything works fine.

    My datasource is a stored procedure and i tried to pass parameter with item=@item and item in (@item) but i got the attached error. Please Help!!!!!

  2. Hristo
    Admin
    Hristo avatar
    1519 posts

    Posted 19 Feb 2018 Link to this post

    Hello Dimi,

    Thank you for writing.

    I am not sure what is the cause of the issue and how it is related to our suite. Can you please record a short video showing how you are receiving the error. In case you keep experiencing it please let me know how I can reproduce it.

    Regards,
    Hristo
    Progress Telerik
    Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  3. Dimi
    Dimi avatar
    2 posts
    Member since:
    Feb 2018

    Posted 21 Feb 2018 in reply to Hristo Link to this post

    As i've read you cant pass multivalue parameter to a stored procedure?am i right with this? so i think that the problem is a result of this.
  4. Nasko
    Admin
    Nasko avatar
    1086 posts

    Posted 26 Feb 2018 Link to this post

    Hi Dimi,

    There are workarounds which you can use to pass a multivalue parameter to a stored procedure:

    How to use MultiValue Report Parameter in a SQL query;
    How to pass multi-value parameters to a Stored Procedure datasource;

    Regards,
    Nasko
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top