Multi-Select List in bootstrap modal.

3 posts, 0 answers
  1. Chinonso
    Chinonso avatar
    42 posts
    Member since:
    Jan 2017

    Posted 16 Feb Link to this post

    Hey there guys and girl, i seem to be having a bit of an issues with the KENDO multi-select list when using it in a bootstrap modal. I have a simple form (_CreatePartial) that is used to add a new person to the. When the form is opened the first time, the multi-select list (car and phone ) load and appear properly but if you close the modal and re-open it, the multi-select lists don't load again.I don't know what exactly could be causing this, I am using the latest version of KENDO (2018.1.117) and latest version of bootstrap-3 (3.3.7). I have attached pictures to show what i see. Thanks for the help



  2. Neli
    Neli avatar
    122 posts

    Posted 20 Feb Link to this post

    Hi Chinonso,

    As you will see in the enclosed screenshot, the Dialog for adding new record is already wrapped in an element with class 'model-content'. So, I would suggest you to remove the class from the form in the _CreatePartial view. This way the duplication will be avoided and the view MultiSelect widgets will be populated correctly. 

    Progress Telerik
    Try our brand new, jQuery-free Angular components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
  3. Chinonso
    Chinonso avatar
    42 posts
    Member since:
    Jan 2017

    Posted 20 Feb in reply to Neli Link to this post

    Thanks a lot . it works great
Back to Top