Missing Telerik menu in VS2017 - still not solved

3 posts, 0 answers
  1. Tony
    Tony avatar
    2 posts
    Member since:
    Jun 2018

    Posted 05 Dec 2018 Link to this post

    I am currently experiencing the missing toolbox in Visual Studio 2017 Professional.

    I have followed the instructions, pinned to to top of the reporting forum, found here: https://www.telerik.com/forums/missing-telerik-menu-in-vs2017.

    I have

    (1) Closed all visual studio instances

    (2) Downloaded the Duplicate Extension finder

    (3) Opened the command prompt as Admin

    (4) Ran the Duplicate Extension Finder tool with the -delete option

    (5) Started Visual Studio 2017 again, as Admin

    (6) Opened the Tools-> Extensions and Updates

    (7) Disables all Telerik and Kendo extension entries

    (8) Restarted Visual Studio 2017 as Admin

    (9) Opened the Tools->Extensions and Updates

    (10) Enabled all Telerik and Kendo extension entries

    (11) Exited and restarted Visual Studio 2017.

    And the problem still exists. The toolbox is not present when I open the report page.

    I have since uninstalled the Reporting component using the Tools -> Extensions and Updates, and also used the Progress Control Panel to uninstall the Telerik Reporting component, demos and Visual Studio 2015 and 2017 extensions, and reinstalled them. I have run theDuplicate Extension Finder to remove and duplicate extensions (there weren't any this time around.)

    But still...nothing. It still isn't showing.

    I can see the ReportingToolbox.12.2.18.1129.pkgdef file under C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\Extensions\Telerik

    I have attached an image from that file. The file references the D drive as that is where I have Telerik Reporting installed (corporate environment, no space on C). The file Telerik.Reporting.dll does exist in that location.

    Is there something I can do to manually force the install of the Telerik Reporting toolbox?

     

     

     

  2. Tony
    Tony avatar
    2 posts
    Member since:
    Jun 2018

    Posted 05 Dec 2018 in reply to Tony Link to this post

    It's ok, I've managed to get it working. To achieve this, I downloaded the msi from my downloads page and ran it. I completely uninstalled Reporting from my machine, then reinstalled it using the downloaded installer. It worked this time. It did not work when I ran it from the Progress Control Panel.
  3. Nikolay Mishev
    Admin
    Nikolay Mishev avatar
    37 posts

    Posted 10 Dec 2018 Link to this post

    Hi Tony,

    This issue does not seem to be a common one and we were unable to reproduce it on our side. However, since you have managed to solve it I would recommend you to contact us before you take any action, if such issue raise again, so we can investigate further.

    Regards,
    Nikolay Mishev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top