Missing Sort Indicator when autoBind is set to False - Release 2020 R2 SP1

6 posts, 1 answers
  1. AGB
    AGB avatar
    71 posts
    Member since:
    Sep 2014

    Posted 30 Jun 2020 Link to this post

    Hi Guys,

    Have just upgraded to Kendo UI 2020.2.617 which reports to include the fixed to the missing sort indicator issue which I raised in February, but I afraid to say this is still not working.

    To illustrate open my original dojo example

        https://dojo.telerik.com/eMELiMut

    and change the library to Kendo UI 2020 R2 SP1 and then run it.

    You will see a sort indicator on the 'Ship Country' column.

    Now if you uncomment 'autoBind:true' and 'dataSource.read();' and re-run you will see that although the data is being sorted correctly the 'Ship Country' column is missing the indicator.

    Regards
    Alan

  2. Petar
    Admin
    Petar avatar
    472 posts

    Posted 01 Jul 2020 Link to this post

    Hi Alan,

    Here is the link to the item that describes the bug in our Feedback portal. Below the "Completed" status of the item, you can see that there is a blue box with the following text - "Release 2020.R2.SP.next". This means that the issue is already fixed, but it will be officially released with our next release. 

    If I am missing something and there is a place where we claim that the fix is released, please send me this link. Thus I will investigate the issue further. If you want to test the fix before the official release, you can download the latest internal build from your profile on www.telerik.com. With it, you can see how the Grid will behave when a new official version is released.

    Regards,
    Petar
    Progress Telerik

    Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
    Our thoughts here at Progress are with those affected by the outbreak.
  3. AGB
    AGB avatar
    71 posts
    Member since:
    Sep 2014

    Posted 01 Jul 2020 in reply to Petar Link to this post

    Hi Petar,

    If you check the Kendo UI 2020 R2 SP1 release notes

             https://www.telerik.com/support/whats-new/kendo-ui/release-history/kendo-ui-r2-2020-sp1

    if reports the problem has been fixed. (See screenshot)

    Therefore it looks like something has failed during build/release process.

    Regards
    Alan

  4. Petar
    Admin
    Petar avatar
    472 posts

    Posted 03 Jul 2020 Link to this post

    Hi Alan,

    Thank you for the provided details and a screenshot. I will need more time to investigate the case. I will write you back with an update about the current ticket at the beginning of the next week. 

    Regards,
    Petar
    Progress Telerik

    Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
    Our thoughts here at Progress are with those affected by the outbreak.
  5. Answer
    Petar
    Admin
    Petar avatar
    472 posts

    Posted 06 Jul 2020 Link to this post

    Hi Alan,

    Here is the update I can share about the current issue. The fix of the discussed bug is not included in the last (2020 R2 SP1)Kendo UI for jQuery version. 

    Listing this bug fix among the Grid's fixes included in the last release is a mistake that will be corrected. I cannot say when this bug fix will be released. This will happen with our next official release. I cannot say if it will be a second service pack(for R2 2020) or out next release will be the R3 2020 release. 

    I've updated your Telerik points as a sign of gratitude for reporting the incorrect listing of the bug fix. 

    Let me know if you have any additional questions related to the current thread.

    Regards,
    Petar
    Progress Telerik

    Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
    Our thoughts here at Progress are with those affected by the outbreak.
  6. AGB
    AGB avatar
    71 posts
    Member since:
    Sep 2014

    Posted 06 Jul 2020 in reply to Petar Link to this post

    Hi Petar,

    Thank you for investigating further and clarifying the situation.

    Regards
    Alan

Back to Top