Mark Error in App.xaml

2 posts, 0 answers
  1. Julio Cesar
    Julio Cesar avatar
    1 posts
    Member since:
    Sep 2014

    Posted 10 Jun Link to this post

                <ResourceDictionary.MergedDictionaries>
                    <ResourceDictionary Source="/Themes/Office2016/System.Windows.xaml"/>
                    <ResourceDictionary Source="/Themes/Office2016/Telerik.Windows.Controls.xaml"/>
                    <ResourceDictionary Source="/Themes/Office2016/Telerik.Windows.Controls.Input.xaml"/>
                    <ResourceDictionary Source="/Themes/Office2016/Telerik.Windows.Controls.Navigation.xaml"/>
                    <ResourceDictionary Source="/Themes/Office2016/Telerik.ReportViewer.Wpf.xaml"/>
                </ResourceDictionary.MergedDictionaries>

     

    Severity Code Description Project File Line Suppression State
    Error  An error occurred while finding the resource dictionary "/Themes/Office2016/Telerik.ReportViewer.Wpf.xaml". WinCont App.xaml 58 
    Error XDG0041 The property "Font" is not a DependencyProperty. To be used in markup, non-attached properties must be exposed on the target type with an accessible instance property "Font". For attached properties, the declaring type must provide static "GetFont"  and "SetFont" methods. WinCont System.Windows.xaml 1 
    Error XDG0012 The member "FontSize" is not recognized or is not accessible. WinCont System.Windows.xaml 1 
    Error XDG0012 The member "VerticalAlignment" is not recognized or is not accessible. WinCont System.Windows.xaml 1 


  2. Neli
    Admin
    Neli avatar
    85 posts

    Posted 11 Jun Link to this post

    Hi Julio,

    We are already discussing the topic in the support thread you opened on the same issue. I will summarize my suggestions for the benefit of our community also here.

    The error message:  An error occurred while finding the resource dictionary "/Themes/Office2016/Telerik.ReportViewer.Wpf.xaml". WinCont App.xaml 58 probably occurs as the XAML designer locks the theme files. To prevent the undesired outcome, please, go to Tools -> Options -> XAML Desginer -> uncheck Enable XAML Designer. Restart the Visual Studio afterwards. Take a look at the attached screenshot for additional reference.

    Regards,
    Neli
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top