This is a migrated thread and some comments may be shown as answers.

Kendo Web with Dataviz

2 Answers 5 Views
Grid
This is a migrated thread and some comments may be shown as answers.
RES
Top achievements
Rank 1
RES asked on 28 Apr 2014, 06:54 PM
I've been having a problem getting the Grid widget to render out.  I've been getting the following output with no table, header or footer.

[object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object][object Object]

I finally traced the problem to a reference to the Dataviz script that I had referenced next to Kendo Web.  I tried the kendo.all and the problem went away but not before wasting a bunch of time trying to figure out what the problem was.  I tried reproducing the problem with one of the Grid examples in the Dojo but no luck.  Should the scripts not be used side by side in this way?

2 Answers, 1 is accepted

Sort by
0
Accepted
Alexander Popov
Telerik team
answered on 30 Apr 2014, 06:34 AM
Hi,

Including the DataViz and Web js files side by side could lead to unexpected behavior. I would recommend checking the JavaScript Dependencies article for additional information on that topic.

Regards,
Alexander Popov
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
RES
Top achievements
Rank 1
answered on 30 Apr 2014, 07:01 PM
Okay that helps, thanks for the tip and I will remember this in the future.
Tags
Grid
Asked by
RES
Top achievements
Rank 1
Answers by
Alexander Popov
Telerik team
RES
Top achievements
Rank 1
Share this question
or