Kendo UI stock chart doesn't display full one year data in zoomout

3 posts, 0 answers
  1. Srikar
    Srikar avatar
    2 posts
    Member since:
    Jun 2018

    Posted 21 Jan 2020 Link to this post

    Hi,

    We are using Kendo stock chart to display  365 days of data, but I can see that the full one year(365 days) data is not being displayed on the category axis in the default/ zoomout mode. But when i zoom in I can see the bars for each day. How can i fix this ? Is this something related to sample rate ? I need to show full data on the category axis.  Attaching images, first img is kendostock chart which won't display all data, second img is KendoChart which displays full set of data. But I need this work with KenoStock chart. Appreciate any help. 

     

     

     

     

     

     

     

     

     

  2. Patrick
    Admin
    Patrick avatar
    235 posts

    Posted 23 Jan 2020 Link to this post

    Hi Srikar,

    There are a few ways in which this issue can be resolved to help visualize the full data of the year:

    1. Set the baseUnit of the CategoryAxis.  This can help format what is being shown based on days, weeks, months, and even years if necessary.
                  categoryAxis: {
                    baseUnit: "days",
                    //...
                  },
    2. Modify the CategoryAxis.labels to your preference.  We have a great Kendo UI Knowledge base article which will give you some configuration options to prevent label clustering.

    Please take a look at the following Progress Kendo UI Dojo which shows one way you can modify the labels in the column chart's categoryAxis.  This can be adjusted based on your configurations.

    Please let me know if you have any questions regarding setting the label position in a Kendo UI Chart.

    Regards,


    Patrick
    Progress Telerik

    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
  3. Srikar
    Srikar avatar
    2 posts
    Member since:
    Jun 2018

    Posted 25 Jan 2020 in reply to Patrick Link to this post

    Thanks, it worked
Back to Top