Kendo scheduler scrolls to up in IE when i'm trying to select a slot.

2 posts, 0 answers
  1. Alex
    Alex avatar
    4 posts
    Member since:
    Jul 2015

    Posted 31 Jul 2015 Link to this post

    Hello,

    kendo scheduler scrolls to up when I'm trying to select slot in the bottom part of the scheduler.
    It works fine in FF, Chrome but not in IE.

    Example in attached file.

    When i specified fixed height of scheduler, it worked fine. But I can't to use fixed height in application because of huge data in all Day section (see screenshot from attached).

    Any ​suggestions please

     

  2. Vladimir Iliev
    Admin
    Vladimir Iliev avatar
    2206 posts

    Posted 04 Aug 2015 Link to this post

    Hello,

    Please note that the described behavior is related to browser specific behavior - when given element is focused the browser triggers "scroll to view" action which automatically move the element to be visible inside current view port. This behavior cannot be prevented and as possible solution I could only suggest to reduce the "height" of the widget in order to be entirely visible in current view port. 

    Another option is to try disabling the Scheduler selection as it's the one that focus the widget element in order to enable the keyboard navigation.

    Regards,
    Vladimir Iliev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
Back to Top