This is a migrated thread and some comments may be shown as answers.

jQuery version and Kendo UI

4 Answers 787 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Miika
Top achievements
Rank 1
Miika asked on 12 Oct 2012, 07:35 AM
Good morning,

I wasn't able to find any reliable seeming information about what version of jQuery Kendo UI requires/supports. Would it be possible to get some sort of official confirmation on this, as I would rather not tie my website to any legacy version of jQuery and then possibly break other libraries.

This page (Javascript Dependencies) shows the jQuery version 1.7.1. But what exactly is meant by this? Is this exact version the only one that Kendo UI supports? Is this the minimum jQuery that is supported (and if that is the case, shouldn't it be listed as 1.7.1+, or 1.7.1 - 1.8.x)? Some of the specific widget examples also use jQuery 1.7.2.

This forum post by Vladimir Iliev says that jQuery 1.8+ can be used with Kendo UI from the 2012 Q2 SP1 version onwards. However, this is the only place I have been able to find that says so. This would be useful information to be "made official" for example in the release blog post for this service pack.

I would like to use Kendo UI, but I don't want to be tied to a legacy jQuery. I can understand if it takes some weeks to confirm compatibility with the very latest version (e.g. 1.8.1 is supported, but 1.8.2 not supported is acceptable. 1.7.x version is not).

4 Answers, 1 is accepted

Sort by
0
Dimo
Telerik team
answered on 12 Oct 2012, 08:25 AM
Hi Miika,

jQuery 1.7.1 which is mentioned in the documentation is the minimum required version - you can't use an older one.

jQuery 1.8.0 introduced breaking changes, which made it incompatible with existing Kendo UI versions. But now it can be used with the latest Kendo UI release (Q2 2012 SP1).

A good way to check what si the "best" jQuery version for Kendo UI is to see what version is used on our online demos. Currently this is 1.7.1, because this was the version used in Q2 2012 and we do not change the "official" jQuery version for service packs. We will most probably upgrade to the latest 1.8.# for Q3 2012 (due next month)

Greetings,
Dimo
the Telerik team
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
0
Miika
Top achievements
Rank 1
answered on 12 Oct 2012, 08:31 AM
Thanks for the speedy reply, and this was exactly what I was hoping to hear.

Regards,
Miika
0
Andrew
Top achievements
Rank 2
answered on 06 Dec 2012, 02:26 PM
Sorry to reopen an old thread - but now that Q3 2012 has been replaced, the dependencies state that a minimum of jQuery 1.8.2 is required. Does this mean that using jQuery 1.7.x will break Kendo after updating to Q3 2012?
0
Dimo
Telerik team
answered on 07 Dec 2012, 06:58 AM
Hello Andrew,

The explicit jQuery 1.8.2 requirement stated in the documentation implies that we do not claim Kendo UI will work correctly with older jQuery versions, and we are testing primarily with the version specified in the documentation.

Regards,
Dimo
the Telerik team
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Tags
General Discussions
Asked by
Miika
Top achievements
Rank 1
Answers by
Dimo
Telerik team
Miika
Top achievements
Rank 1
Andrew
Top achievements
Rank 2
Share this question
or