Inconsistent and Odd Tile Content Behaviour

4 posts, 0 answers
  1. Mike
    Mike avatar
    28 posts
    Member since:
    Apr 2013

    Posted 10 Jul 2015 Link to this post

    I've recently added a new tile to my main tiles in the app. This tile takes a twitter feed and displays a list of the tweets. I've had to extract the links out to a separate property, which I then bind to a Hyperlink. To keep the latest tweets on the top I use a ViewSource which is a resource on the user control the TileList is part of.

    The odd behaviour is that the links aren't always clickable. If I take the RadListBox out of the tile and into a grid in another part of the page it works perfectly all the time. I've deployed the app to a couple of test machines and on one of those the links are always clickable on the tile until you change the theme, then they break. On my local dev box, the clickability of the links is inconsistent. I can fire the app up in VS2013 10 times and out of that maybe 3 times it will work.

    I've put together a quick video showing the issue: Tile Issues Video

    The code for the tile is below. In the Grid, that works, the exact same RadTileList piece of code is used. 


    <tel:Tile x:Name="tileTweetFeed"
               AllowDrop="False" Focusable="False">
                 <RowDefinition Height="Auto"/>
                 <RowDefinition Height="*"/>
             <TextBlock Text="vrHive Twitter Feed"
                        FontFamily="/vrHive;component/Fonts/#Zero Threes"
                        FontSize="11" />
             <Border Visibility="Visible" Grid.Row="1" 
                     Background="#FF386DDA" >
                 <Grid >
                         <RowDefinition Height="*"/>
                     <tel:RadListBox x:Name="listTweetFeed" ItemsSource="{Binding Source={StaticResource ItemListViewSource}}" Background="{x:Null}"  >          
                             <DataTemplate >
                                 <Grid Margin="0">
                                         <RowDefinition />
                                     <TextBlock FontWeight="Bold"
                                                Text="{Binding twitterMessage.CreatedDate}"
                                     <TextBlock Grid.Row="1"
                                                Text="{Binding twitterMessage_NoLink}"
                                                HorizontalAlignment="Left" />
                                     <Grid Grid.Row="2" Margin="10,2,0,0" Visibility="{Binding twitterMessage_Link, Converter={local:EmptyStringToVisibilityConverter}}">
                                             <ColumnDefinition Width="45"/>
                                         <StackPanel Grid.Column="0"
                                             <TextBlock Grid.Column="0" Text="Link(s): "  />
                                         <tel:RadListBox Grid.Column="1"
                                                  ItemsSource="{Binding twitterMessage_Link}"
                                                  BorderThickness="0" >
                                                     <StackPanel Orientation="Vertical"
                                                         <Hyperlink NavigateUri="{Binding}" 
                                                             <TextBlock Text="{Binding}"


    I've tried changing the parent container for the RadTileList and that makes no difference. I've also tried dropping the RadTileList and using a standard ListBox and ListView, but neither of those works.

    Is there a way I can get around this odd behaviour? 

  2. Vera
    Vera avatar
    267 posts

    Posted 14 Jul 2015 Link to this post

    Hello Mike,

    I tried to reproduce the issue using the provided details and code but I was not able to. Attached you can find the project I used for the test. Do you get the same behavior on it?
    I got the impression from your last sentence that the problem can be reproduced outside of the TileList? Is that correct? 
    According to this ticket info, you are currently using Q2 2015 (2015.2.623). In case you are using an older one, please download our latest official version and give it try.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Mike
    Mike avatar
    28 posts
    Member since:
    Apr 2013

    Posted 14 Jul 2015 in reply to Vera Link to this post

    Thanks for the reply. 

    I'll try the demo project when I'm back home on Friday. I did upgrade to the latest release, so yes I'm on the Q2 version. 

    As for reproducing the issue, if I take the content of the tile, i.e the xaml within the border control, and put that code somewhere else then the links always work, as per the top left corner of the video. But when the same xaml is within a TileView/Tile control then I get the behaviour described. If I replace the RadListBox's with standard WPF controls (ListBox/ListView) the behaviour is still inconsistent. I should have said "I've also tried dropping the RadListBox..." instead of "I've also tried dropping the RadTileList..." in that last sentence, sorry.


  4. Mike
    Mike avatar
    28 posts
    Member since:
    Apr 2013

    Posted 14 Jul 2015 in reply to Mike Link to this post


    I've had a look and used an old version of my app, as I'm away from home to test with and your demo works fine, as you would expect. The only difference I could see is that I have a RadBusyIndicator wrapping the TileList. If I remove the RadBusyIndicator from my code then I get no issues and it works as in your demo. If I add a RadBusyIndicator to your demo then it also works. 

    It appears that when I switch viewmodels and then come back to this mainmenuview then with the RadBusyIndicator it does something odd with the links. No RadBusyIndicator and all is well. 

    So for now I'm going to remove the RadBusyIndicator and take another approach for when I need the tiles all disabled. 


Back to Top