Html5 Report Viewer with Android 9

5 posts, 0 answers
  1. Rich
    Rich avatar
    7 posts
    Member since:
    Dec 2014

    Posted 18 Jun Link to this post

    I've had users tell me that the parameters area of the report viewer is no longer clickable on devices running the latest version of Android. This is one description:

    "I can open the filter and see everything but clicking is unresponsive.
    It's weird though, it will outline the element so it knows that something is being clicked there but it just doesn't select or deselect the element."

    Has anyone else run into this issue? Is there a work-around or fix?

  2. Neli
    Admin
    Neli avatar
    125 posts

    Posted 21 Jun Link to this post

    Hi Rich,

    We have not experienced such issue so far and I will need a few more things to know before we start testing:
    - what is the exact version of the Android OS?
    - what was the used web browser?
    - what are the brand and the model of the mobile device(s);
    - what is the resolution of device(s)?
    - share any other information which you think will be relevant.

    Regards,
    Neli
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Rich
    Rich avatar
    7 posts
    Member since:
    Dec 2014

    Posted 24 Jun in reply to Neli Link to this post

    Hi Neli,

    I don't personally have an Android device so it took me a little bit to gather this information.

    - what is the exact version of the Android OS? == The phone says Android version is just 9. The kernel version is 3.18.131.g27a6e3d260f4
    - what was the used web browser? == Chrome 74.0.3729.157
    - what are the brand and the model of the mobile device(s); == Google Pixel
    - what is the resolution of device(s)? == 5 inch 1080 x 1920

    I guess the only other relevant thing is that this is the device that our internal QA team used to confirm the issue, but it has been reported on other devices as well. Android 9 seems to be the common thread. Things seem to work as expected on Android 8 in our testing.

  4. Rich
    Rich avatar
    7 posts
    Member since:
    Dec 2014

    Posted 24 Jun in reply to Rich Link to this post

    I guess one other thing. I am currently using 12.1.18.824 of the ReportViewer. I know that is not the latest. I generally don't update unless there's something specific I need, but if updating should address this issue, I will do so.
  5. Neli
    Admin
    Neli avatar
    125 posts

    Posted 27 Jun Link to this post

    Hello Rich,

    We made some tests with our online demos on few devices with Android 9. The issue was not reproduced. It will be really useful for us, if you share a screenshot of the settings of the report parameter, so we can test further. Can you also check if the issue will be reproduced with our online demos?
    We have made improvements in the Html5 Viewer since R2 2018, so upgrading may fix the problem. However, since we cannot reproduce locally, we cannot guarantee this. Testing with online demos (they use the latest version) may answer this question.

    If possible, please, open a Support ticket and send us the problematic report to test also with it. 

    Regards,
    Neli
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top