HTML5 Report Viewer. 404 Error when refreshing.

3 posts, 0 answers
  1. Eric
    Eric avatar
    19 posts
    Member since:
    Dec 2012

    Posted 07 May 2015 Link to this post

    I'm using the HTML5 Report Viewer. Everything seems to be working fine but when I refresh the report using the refresh button on the Report Viewer, I get a 404 error. From what I saw in Fiddler it looks like when I hit the refresh button its called the DeleteInstance action on the base controller. The call looks like this mysite/api/reportsdata/clients/154459-b20c/instances/163052-40f7 I'm hoping someone can shed some light on this issue.

  2. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 08 May 2015 Link to this post

    Hello Jet,

    Please download and install the latest available Telerik Reporting Q1 2015 SP1 internal build v9.0.15.422 (your Telerik account - Products & subscriptions - Latest internal builds - Reporting). You will need to run the Upgrade Wizard in all projects having references to Telerik Reporting.
    The upgrade is recommended due to the changes we included in the mentioned internal build (synchronization of requests for ICache implementations and cache timeout settings, which can be tested with our local demos under C:\Program Files (x86)\Telerik\Reporting Q1 2015\Examples\CSharp).


    Then depending on the way the application is hosted consider using ICache or Istorage implementation for the Reporting REST service's Storage. For more details check REST service storage and the linked in it articles.


    On a side note, verify the Reporting REST service is configured correctly and all required Nuget packages are installed in the project - How To: Add Telerik Reporting REST Web API to Web Application. Also on deploying the service, check if the machine has enabled WebDAV module and remove it (example).

    Regards,
    Stef
    Telerik
     

    See What's Next in App Development. Register for TelerikNEXT.

     
  3. Eric
    Eric avatar
    19 posts
    Member since:
    Dec 2012

    Posted 08 May 2015 in reply to Stef Link to this post

    Adding the runAllManagedModulesForAllRequests="true" attribute to the modules element and adding <remove name="WebDAVModule"/> resolved the issue for me. Thanks a lot. 
Back to Top