How to use localized (German) Number Format in RadGridView?

4 posts, 0 answers
  1. Peter
    Peter avatar
    37 posts
    Member since:
    Dec 2011

    Posted 20 Jan 2014 Link to this post

    How do I localize the number format used in RadGridView for double to German culture (1.23 is written in German culture 1,23)?

    Take a very simple RadGridView like in the "Getting Started" example for RadGridView (http://www.telerik.com/help/wpf/gridview-getting-started2.html).
    On a clean new VS2010 Telerik RadControls project on my German Win7 machine, the header block ("Drag a column header and drop it here ...") is displayed correctly in German ("Ziehen Sie einen Spaltenkopf auf diese Fläche ..."), but cells of columns that represent a  property of type double will not work correctly with German culture. When I enter e.g. the German value half (0,5) it will be interpreted as five (5).

    How do I change this?

    I already tried

                InitializeComponent();
                LocalizationManager.DefaultCulture = new System.Globalization.CultureInfo("de");

    But it does not work...

  2. Yoan
    Admin
    Yoan avatar
    1214 posts

    Posted 20 Jan 2014 Link to this post

    Hi Peter,

    Thank you for contacting us.

    I would suggest you to check this troubleshooting article for a reference.

    I hope this helps.


    Regards,
    Yoan
    Telerik
    TRY TELERIK'S NEWEST PRODUCT - EQATEC APPLICATION ANALYTICS for WPF.
    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  3. Peter
    Peter avatar
    37 posts
    Member since:
    Dec 2011

    Posted 20 Jan 2014 Link to this post

    That solved it! Thank you, Yoan!
  4. Mende
    Mende avatar
    2 posts
    Member since:
    Oct 2010

    Posted 15 May 2014 Link to this post

    Good evening.
    For me, setting IsLocalizationLanguageRespected=False on the RadGridView solved the problem.
    Cheers
Back to Top