This is a migrated thread and some comments may be shown as answers.

How to disable DatePicker's auto completion with typing

0 Answers 21 Views
Calendar, DateTimePicker, TimePicker and Clock
This is a migrated thread and some comments may be shown as answers.
William
Top achievements
Rank 1
William asked on 30 Nov 2018, 08:50 PM
I have a DatePicker (not DateTimePicker) and want to add functionality to it.  If I type "t" it displays today's date.  This part works, but I also want to add t-n/t+n where n is the number of days to add or subtract from today's date.  However, whenever you type a number into a DatePicker, it automatically assumes the same month and year and outputs whatever number you type as the date.  For example if i type t+4, and today's date is 11/20/2018, it displays 11/4/2018, even though, through debugging, it does hit the line that should display 11/24/2018.  It appears to run OnValueChanging a second time, imputing what telerik thinks I want.  Is there anyway to disable this, or cancel it once it starts?

No answers yet. Maybe you can help?

Tags
Calendar, DateTimePicker, TimePicker and Clock
Asked by
William
Top achievements
Rank 1
Share this question
or