How do i get rid of the popup in wpf designer mode.

5 posts, 1 answers
  1. Mike
    Mike avatar
    5 posts
    Member since:
    Mar 2017

    Posted 08 Mar Link to this post

    See the image below. Obviouslly i can click the white x at the top right hand corner but it just reappears when i click another telerik control
  2. Answer
    Milena
    Admin
    Milena avatar
    226 posts

    Posted 13 Mar Link to this post

    Hello Mike,

    I am sorry to hear about the issues you are experiencing. 

    I tested it on our side and I can confirm that this is a bug and therefore I logged in in our Feedback portal where you can track its progress. I have also updated your Telerik points as a small appreciation for your cooperation. 
    The issue is connected with the Smart Tags functionality which provides easy way to go to helpful documentation articles and demos related to each control. But it should not appear when click on a control in xaml view. You said that it "reappears when click another telerik control" - it is reproducible with other controls (except ribbon controls) too? 

    Please excuse us for any inconvenience caused.

    Regards,
    Milena
    Telerik by Progress
    Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
  3. Mike
    Mike avatar
    5 posts
    Member since:
    Mar 2017

    Posted 23 Mar Link to this post

    ive added a comment to your post. the way it is now, its almost impossible to code strictly in xaml view
  4. Mike
    Mike avatar
    5 posts
    Member since:
    Mar 2017

    Posted 23 Mar Link to this post

    is it possible to disable the window all together?
  5. Milena
    Admin
    Milena avatar
    226 posts

    Posted 27 Mar Link to this post

    Hello Mike.

    The issue is really annoying and I increased its priority because it blocks the xaml writing. Can you tell us if it is reproducible with each ribbon control or only clicking on RadRibbonDropDownButton/SplitButton brings the design view into full screen?

    In the meantime I could suggest the following: 
    - if you are not using the design view at all, you can disabled it. E.g.for Visual Studio 2015 you can unchecked the following: Tools->Options->XAML Designer\Enable XAML Designer; 

    - another approach is to delete the files in design folder: ...Program Files (x86)\Telerik\UI for WPF R1 2017\Binaries\WPF40\design. If you try this you need also to clear the shadow cache of Visual Studio. In order to achieve this you should do the following:
    1) Close all visual studio instances.
    2) Go to  C:\Users\<username>\AppData\Local\Microsoft\VisualStudio\<visual_studio_version,for_example_12.0>\Designer\ShadowCache and delete the folders there - this is the cache of VisualStudio's designer;

    - or you can open the xaml and design in split view as you can see from the attached picture - so the popup will be open but you can continue to write in xaml view; 


    Please let me know if this helped.

    Regards,
    Milena
    Telerik by Progress
    Want to extend the target reach of your WPF applications, leveraging iOS, Android, and UWP? Try UI for Xamarin, a suite of polished and feature-rich components for the Xamarin framework, which allow you to write beautiful native mobile apps using a single shared C# codebase.
Back to Top