How can i disable editing of a column ?

9 posts, 0 answers
  1. Tarun
    Tarun avatar
    16 posts
    Member since:
    Jan 2011

    Posted 30 Aug 2011 Link to this post

    I have a GridViewComboBoxColumn. I dont want the users to be able to edit the data in the column. I am setting the IsEnabled to False but that does not work. Please advise

    <telerik:GridViewComboBoxColumn DataMemberBinding="{Binding Author}" ItemsSource="{Binding Authors}" SelectedValueMemberPath="Initials" DisplayMemberPath="LastName" Width="100" IsEnabled="False" />
  2. Maya
    Admin
    Maya avatar
    4062 posts

    Posted 31 Aug 2011 Link to this post

    Hi Tarun,

    You need to set the IsReadOnly property of the column to "True".
     

    Greetings,
    Maya
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Siva Prakash
    Siva Prakash avatar
    14 posts
    Member since:
    Sep 2011

    Posted 28 Dec 2011 Link to this post

    Hi,

    When I want to disable a column, I am making use of its IsReadOnly property and setting it to true. Its working fine. But I want to show the ReadOnly column as a grayed out one. How can I do this.

    Regards
    K Siva Prakash.
  4. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 28 Dec 2011 Link to this post

    Hello,

     
    Please check this forum thread "Styling ReadOnly column". The same approach is applicable to WPF as well. 


    Regards,
    Vanya Pavlova
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  5. aries
    aries avatar
    3 posts
    Member since:
    Aug 2014

    Posted 11 Aug 2014 Link to this post

    Hi
    Can anyone help me with disabling a radgridcombobox from a cell in the radgridview
  6. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 13 Aug 2014 Link to this post

    Hello,

    Configuring GridViewComboBoxColumn with IsReadOnly="True" should disable editing in it. I am not sure I understand your question. Would you please clarify it?

    Regards,
    Didie
    Telerik
     
    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
     
  7. aries
    aries avatar
    3 posts
    Member since:
    Aug 2014

    Posted 14 Aug 2014 in reply to Dimitrina Link to this post

    I'm not able to reproduce the issue here....Is there anyway that I can do join.me with you inorder to show what im looking for ......................
  8. aries
    aries avatar
    3 posts
    Member since:
    Aug 2014

    Posted 14 Aug 2014 Link to this post

    please find the attached files for reference on fix needed. The xaml file is where changes are needed for the party column where a radgridcombobox column is assigned which has drop down values as groom and bride. All I need is to remove the combobox and replace it with groom in the first row column and bride in the second row column as shown In the screenshot .
  9. Dimitrina
    Admin
    Dimitrina avatar
    3769 posts

    Posted 15 Aug 2014 Link to this post

    Hi,

    If you would like to change the ItemTemplate of the editor of GridViewComboBoxColumn, they you can apply a proper EditorStyle
    It seems the file was not attached. You can open a new support ticket on the matter and attach it there.

    Regards,
    Didie
    Telerik
     
    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
     
Back to Top