Horizontal scrollbar is overlapping the last row of data.

0 Answers 55 Views
GridView
Martin
Top achievements
Rank 2
Iron
Iron
Iron
Martin asked on 13 Jul 2022, 10:44 AM

I'm using the latest version of Telerik UI for WPF - Framework 4.8

and i have the same issue as described here: https://www.telerik.com/forums/the-scroll-bars-are-placed-in-the-tables

from April .. 

Will this issue get fixed sometime soon ? 

or is there a quick fix ?

Stenly
Telerik team
commented on 18 Jul 2022, 09:57 AM

I have tried to reproduce this behavior, however, on my end, the scrollbars are not displayed over the last row. May I ask if you could provide a bit more information regarding this behavior? More specifically, what theme is being used? Also, I have attached the test project, so, could you give it a try and let me know if I am missing something?
Asem
Top achievements
Rank 1
commented on 09 Nov 2022, 07:32 AM | edited

 

Hello @Stenly , I have integrated your code in my project and here is the result :( always there is a problem

 

this is what we need

Skurken
Top achievements
Rank 1
commented on 09 Nov 2022, 01:51 PM

Hi Asem .. i fail to see the problem i described in your pictures. 

My issue was that the last element in the list i hidden by the scollviewer - on your pictures i can see the whole element when scrolled to the end. 

Stenly
Telerik team
commented on 11 Nov 2022, 02:24 PM

Hello Asem,

Looking at the first image that you have provided, it seems that the Fluent theme is being used. By design, the scrollbars are displayed over the content. A possible way to prevent the scrollbars from hiding certain cells would be to change the ScrollBarsMode property to Compact. This way, the bars will not expand on a mouseover and will stay narrow.

Alternatively, a different theme could be used. Currently, this design choice is present only in the Fluent and Crystal themes. 

I hope the provided information will be of help to you.

Skurken
Top achievements
Rank 1
commented on 11 Nov 2022, 03:08 PM

Hi Stenly 

I just tried setting the ScrollBarsMode to Compact ( inside MainWindow()  constructor ) - it doesnt work ?

Is there a correct place to add this line of code :

FluentPalette.Palette.ScrollBarsMode = Telerik.Windows.Controls.Theming.ScrollViewerScrollBarsMode.Compact;

Scrollbars still look like normal.

Martin Ivanov
Telerik team
commented on 14 Nov 2022, 08:08 AM

The ScrollBarsMode should be set before the Telerik components are initialized. For example, you can do this in the App class, or in the static constructor of the MainWindow or in the instance constructor of MainWindow, but before the InitializeComponent call. For example:

static MainWindow()
{
     FluentPalette.Palette.ScrollBarsMode = Telerik.Windows.Controls.Theming.ScrollViewerScrollBarsMode.Compact; 
}

Skurken
Top achievements
Rank 1
commented on 14 Nov 2022, 08:18 AM

Thanks.

I can't make it work.

I think that the MahApps.Metro theme is somehow overriding the scrollbar styling. 

Martin Ivanov
Telerik team
commented on 16 Nov 2022, 01:34 PM

Possibly. Telerik applies a custom style for the WPF native ScrollViewer control to achieve the Fluent look and feel. If the MahApps.Metro styles do the same, there could be a conflict. What you can try is to define the Telerik resources after the MahApps.Metro ones. If this doesn't help, I would suggest you to open a new support ticket and attach the project with the troublesome behavior there.

No answers yet. Maybe you can help?

Tags
GridView
Asked by
Martin
Top achievements
Rank 2
Iron
Iron
Iron
Share this question
or