Hierarchical GridView Vertical Blank Space Between Rows

2 posts, 0 answers
  1. Jason Intardonato
    Jason Intardonato avatar
    5 posts
    Member since:
    Mar 2010

    Posted 02 May 2014 Link to this post

    I've implemented a hierarchical GridView with RadGridView in WPF and bound it MVVM style to an ObservableCollection of some custom object A which expose a child property which again is another ObservableCollection of some other type B.  It binds correctly and for the most part behaves correctly (virtualization doesn't work) but it is including a varying amount of blank vertical space between the top level rows which seems to correlate to some degree with the number of rows in the child GridView.

    Seems like the GridView is just not able to correctly measure and size the vertical space necessary to accommodate the rows.

    I've tried setting a fixed height on the container element which is a grid, setting the rowheight, the visiblerowheight, disable vertical scrolling - nothing seems to make a difference.

    Desperate for a solution. Getting ready to throw in the towel and write my own regular ol' hierarchical data grid.

    Any ideas?

  2. Vera
    Admin
    Vera avatar
    268 posts

    Posted 05 May 2014 Link to this post

    Hello Jason,

    Could you try setting RadGridView.GroupRenderMode property to Flat? GroupRenderMode Flat was introduced with Q2 2013 as a completely new logic for group rendering. The result was faster scrolling and very good performance, but it fixed a lot of other issues reproducible with the old Nested mode. This is way we recommend using the new rendering logic.


    Regards,
    Vera
    Telerik
     
    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
     
Back to Top