This is a migrated thread and some comments may be shown as answers.

Headers in CSV Exported files shows textbox1,2,3 instead of Name of the Textbox

1 Answer 90 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Savan
Top achievements
Rank 1
Savan asked on 16 Aug 2017, 08:26 AM

Hello,

I am using Teleril Report version 11.1.17.503. When i export the report to csv format the headers in the csv files shows textbox1, textbox2, textbox3 onwards. i searched for similar issues on Report Forum and found one solution where you guys have suggested to set NoHeaderText to true in web.config file. i have applied that changes but still when i export my report into csv format it shows textbox1, textbox2 onwards. the changes i made in web.config file is as mentioned below:

 

  <Telerik.Reporting>
    <Extensions>
      <Render>
        <Extension name="CSV">
          <Parameters>
            <Parameter name="NoStaticText" value="true"/>
          </Parameters>
        </Extension>
      </Render>
    </Extensions>
  </Telerik.Reporting>

i followed instructions from this page http://www.telerik.com/support/kb/reporting/details/configuring-the-csv-rendering-extension

I really need to how the headers as actual name i specified in report.

 

Kind Regards,

Savan K. Parmar

1 Answer, 1 is accepted

Sort by
0
Nasko
Telerik team
answered on 18 Aug 2017, 06:03 AM
Hello Savan,

When exporting to CSV, the first record contains headers for all the columns in the report (the items' name, not value). This behavior is by design and is described in the Design Considerations for CSV Rendering help article. You will need to manually set the names (TextBox.Name property) of the text boxes in order to change the header text in the exported CSV file.

If the above solution is not applicable in your scenario, then you will need to hide the headers entirely using the NoHeader parameter from the article that you mentioned:
<Telerik.Reporting>
  <Extensions>
    <Render>
      <Extension name="CSV">
        <Parameters>
          <Parameter name="NoHeader" value="true"/>
        </Parameters>
      </Extension>
    </Render>
  </Extensions>
</Telerik.Reporting>


Regards,
Nasko
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Savan
Top achievements
Rank 1
Answers by
Nasko
Telerik team
Share this question
or