This is a migrated thread and some comments may be shown as answers.
GridViewIndentCell hidden and resulting row width
1 Answer 7 Views
This is a migrated thread and some comments may be shown as answers.
John
Top achievements
Rank 1
John asked on 25 Jun 2014, 03:04 PM
Hello,
I have a GridView with one column with width "*", and the rest "Auto", which allows for the user resizing the window.

I am hiding the Group Indent Cell using this:

<Style TargetType="telerik:GridViewIndentCell">
    <Setter Property="Visibility" Value="Collapsed"/>
</Style>

but this seems to still affect the width of the resulting row since I end up with a gap at the end of the row which I can't use and can't click. It appears to me that the row is sized before the GridViewIndentCell is hidden, and the row is not resized again to allow for the extra width. (See attached screenshot).

1. Is there a way of removing this gap?
2. I would also like to turn off the border round the currently selected cell and can't find a way to do this.

Any help would be appreciated.

Thanks,
John

1 Answer, 1 is accepted

Sort by
0
Dimitrina
Telerik team
answered on 26 Jun 2014, 03:02 PM
Hello John,

As to your questions:
1. This gap is the background of RadGridView behind GridViewRow, which is shorted after you hide the GridViewIndentCell. I am afraid this cannot be changed. You can still set the same Background for RadGridView and its elements, so that the gap is not so much visible. 
2. You can check this help article for a reference on how to remove the border of the current cell. 

Regards,
Didie
Telerik
 
Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
 
Asked by
John
Top achievements
Rank 1
Answers by
Dimitrina
Telerik team
Share this question
or