GridTemplateColumn behaving oddly

1 posts, 0 answers
  1. Max
    Max avatar
    21 posts
    Member since:
    Apr 2016

    Posted 12 Jul 2017 Link to this post

    Hello, I need to change a GridTemplateColumn to no longer be editable and instead have the former EditItemTemplate appear when adding a row instead in two different grids.

    I tried just changing the EditItemTemplate elements into InserttemTemplate elements. This worked for one grid, however in the other grid it still seems to show the EditItemTemplate for that column when editing the row and not showing it when inserting. What could be going on?

    Here is the grid element where it worked:

    <telerik:RadGrid ID="ItemGrid" runat="server"
                            AutoGenerateColumns="False" GridLines="None" Skin="WebBlue" Width="210px"
                            AllowMultiRowEdit="true" AllowFilteringByColumn="false"
                            OnNeedDataSource="ItemGrid_NeedDataSource" EnableLinqExpressions="false">
                            <GroupingSettings CaseSensitive="false" />

     

    And the one where it didn't work:

    <telerik:RadGrid ID="ItemGrid" runat="server" 
                            AutoGenerateColumns="False" GridLines="None" Skin="WebBlue" Width="860px"
                            AllowMultiRowEdit="true" AllowFilteringByColumn="false"
                            OnNeedDataSource="ItemGrid_NeedDataSource" EnableLinqExpressions="false"
                            OnItemDataBound="ItemGrid_DataBound"
                            ClientSettings-ClientEvents-OnBatchEditClosed="ItemGrid_BatchEditClosed"
                            ClientSettings-ClientEvents-OnBatchEditCellValueChanging="ItemGrid_BatchEditCellValueChanging"
                            ClientSettings-ClientEvents-OnBatchEditOpened="ItemGrid_BatchEditOpened">

     

     

    Besides the elements here the only difference is they have a different number of columns. Both grids are on the same page. I also tried just removing the ClientSettings-ClientEvents-OnBatchEdit* and OnItemDataBound properties from the second grid and the same problem still occurs.

     

Back to Top