Grid will not tab to next field

3 posts, 0 answers
  1. Jerry
    Jerry avatar
    4 posts
    Member since:
    Jul 2010

    Posted 08 Mar 2013 Link to this post

    I have a kendo grid set up for batch mode, GridEditMode.InCell.  After entering data in any field and pressing 'Tab', the 'Delete' key gets focus.  The editing example in the Kendo.Mvc.Examples source exhibits the same behavior.  

    The online batch editing example (http://demos.kendoui.com/web/grid/editing.html) tabs to each field correctly.   My view is set up like the online demo.

    Is there a setting I'm missing to allow this behavior?


    Thanks,

    Jerry




  2. Vladimir Iliev
    Admin
    Vladimir Iliev avatar
    2206 posts

    Posted 12 Mar 2013 Link to this post

    Hi Jerry,

     
    Basically you should enable the Navigatable option of the grid to achieve the desired behavior.

    e.g.:

    @(Html.Kendo().Grid<Kendo.Mvc.Examples.Models.ProductViewModel>()   
        .Name("Grid")   
        .Columns(columns => {       
            columns.Bound(p => p.ProductName);
            columns.Bound(p => p.UnitPrice).Width(140);
            columns.Bound(p => p.UnitsInStock).Width(140);
            columns.Bound(p => p.LastSupply).Width(300).Filterable(f => f.UI(GridFilterUIRole.DateTimePicker));
            columns.Command(command => command.Destroy()).Width(110);
        })
        //enables the keyboard navigation
        .Navigatable()
    Kind Regards,
    Vladimir Iliev
    the Telerik team
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Frank
    Frank avatar
    1 posts
    Member since:
    Dec 2015

    Posted 06 Mar 2017 in reply to Vladimir Iliev Link to this post

    Thanks this was vary helpful 
Back to Top