This is a migrated thread and some comments may be shown as answers.

Graph not looking right

1 Answer 7 Views
Chart
This is a migrated thread and some comments may be shown as answers.
Alex
Top achievements
Rank 1
Alex asked on 27 Mar 2012, 08:44 PM
I have a large amout of data displayed in a graph.  The probelm I'm having is that I'm not getting the graph that I expect, it's like that radgraph is smothing everything out by taking a average or something, I don't want everything smoothed out.  I want the jagged lines.  When I zoom in it looks like all the data is there, it gets jagged, but zoomed out I get somthing that dosn't look right.

1 Answer, 1 is accepted

Sort by
0
Evgenia
Telerik team
answered on 30 Mar 2012, 03:49 PM
Hi Alex,

You are not doing anything wrong.
This is a feature of the RadChart called Sampling. You can read about it here.

To improve performance when working with a huge number of items the RadChart combines (clusters) some of the items. It combines some items with close values and shows them as a single DataPoint (with average estimates for the X and Y).

You have control of how many DataPoints will be visualized by setting the SamplingThreshold property. (By default it is 200).

In your case you need to fully disable Sampling. To disable Sampling you need to set the SamplingThreshold to 0.

<telerikChart:RadChart x:Name="radChart">
    <telerikChart:RadChart.SamplingSettings>
        <telerikCharting:SamplingSettings SamplingThreshold="0" />
    </telerikChart:RadChart.SamplingSettings>
</telerikChart:RadChart>

I hope this helps.

All the best,
Evgenia
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Tags
Chart
Asked by
Alex
Top achievements
Rank 1
Answers by
Evgenia
Telerik team
Share this question
or