Getting exception when trying to add RadNumericUpDown

3 posts, 0 answers
  1. James
    James avatar
    7 posts
    Member since:
    Mar 2011

    Posted 13 Jul 2011 Link to this post

    When I try to drag a RadNumericUpDown control from the Toolbox over onto a WPF designer-view Window, I'm getting an Error Dialog that says:
    Set property 'System.Windows.ResourceDictionary.Source' threw an exception.
    "Cannot locate resource 'themes/genericmetro.xaml'."

    What is going on here?  I have used this control before in another project and it worked great.

    I just today updated to the Q4 2011 update. I'm running VS 2010 Ultimate SP1 on Windows 7 x64 Ult. My application is targeting .NET Framework 4.0.   As my mother always used to ask me.. "What did you break now?!"  lol

    Thanks for your help,
    James W. Hurst
  2. Pana
    Pana avatar
    748 posts

    Posted 19 Jul 2011 Link to this post

    Hi James,

    Your mother is one smart woman... I have no idea what we have broken. Have you tried to remove the old installation, clean the GAC and if this does not help could you try to move away the design dlls from the installation folder. Don't delete them just move them to your desktop for example, close and open the studio and if this does not fix your problem move them back.

    Does it brake in design time only? In other words - does it build and work in runtime? I don't think it has something to do with the OS and VS it looks more like a version mismatch between the dlls.

    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  3. James
    James avatar
    7 posts
    Member since:
    Mar 2011

    Posted 19 Jul 2011 Link to this post

    You are quite right.

    Your suggestion seemed the most sensible explanation. I removed all of the DLLs, uninstalled Telerik completely, downloaded the newest versions and reinstalled. Now, the problems are gone. I can drag widgets over onto the design surface and it just works.

    Thank you so very much!
Back to Top