FIDDLER v5.0 unable to start properly (Failed to registeras the system proxy)

4 posts, 0 answers
  1. Zajec
    Zajec avatar
    2 posts
    Member since:
    Mar 2018

    Posted 13 Mar 2018 Link to this post

    Fiddler v5.0.20173.50948 unable to start properly on my PC with Windows 10 (Fall Creators Update installed). When I am opening Fiddler, I always get a message: "Failed to register Fiddler as the system proxy." And this is the very big problem, because I am using Fiddler all the time. Why is not working? Is it because of Fall Creators Windows10 Update?

    I also saw that service "Web WinHTTP" is not working and I cannot start it because I get message: "access denied" or "1067 error".

    When I edit the reg to force start "Web WinHTTP" service and restart the PC, I don't have internet connection at all and my PC is working unstable, programs are crashing or opening very long... why is that happening? How can I fix it?

    I am waiting for advices,

    Best Regards,
    Matthew

  2. Zajec
    Zajec avatar
    2 posts
    Member since:
    Mar 2018

    Posted 14 Mar 2018 Link to this post

    Can someone help me?
  3. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    549 posts

    Posted 19 Mar 2018 Link to this post

    Hello,

    We cannot really help with configuring WinHTTP on your system. As for Fiddler it is hard to say why proxy setup fails based on the information you provide. You could always manually set Fiddler to be a system proxy, though. I.e. you could change  your system proxy settings to point to 127.0.0.1:8888 when Fiddler is running (provided you haven't changed the 8888 port in Fiddler settings). That should make Fiddler work and in the process you might also find out why the automated setting fails.

    Regards,
    Tsviatko Yovtchev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Eitan
    Eitan avatar
    5 posts
    Member since:
    Sep 2015

    Posted 29 Sep 2018 Link to this post

    The solution is in the following link, but you have to reboot after applying it to make is active.
    http://www.rudyhuyn.com/blog/2018/01/10/how-to-fix-fiddler-when-it-cant-set-the-proxy-on-windows-10/


    A copy of the text, if the link will vanish one day:
    "
    Type Windows+R and enter services.msc is the textbox.
    Then look for WinHTTP Web Proxy Auto-Discovery Service, right click and select Properties.
    Change the startup type to Automatic and then click on Start.
    If for any reason you can’t change the startup type cause disabled, open regedit, go to HKLM\SYSTEM\CurrentControlSet\services\WinHttpAutoProxySvc and change start value to 2.
    "
Back to Top