First, for your information, French is my mother tongue, so it's why I'm sending these corrections.
1. For "Ko" vs "ko", look at this Wikipedia page https://fr.wikipedia.org/wiki/Kilo (English page: https://en.wikipedia.org/wiki/Kilo-). Here you can find that, officially, the symbol for "kilo" is a lowercase "k"
There is also a distinction between a kilobit, which is 1000 bits and a kibibit, which is 1024 bits (French page: https://fr.wikipedia.org/wiki/Kilobit, English page: https://en.wikipedia.org/wiki/Kilobit). Even Windows Explorer is wrong, because it says "kilobyte" for 1024 bytes, that explains why a 1TB hard disk has only about 935MB free in Windows.
2. "octet(s)" vs "octets". It's as in English: if you want to be purist, you should write "octet" if there is only one and "octets" if the are at least two.
3. I've written long time ago a method to format correctly the size of a file and just corrected it for .NET Core, with all the remarks above. The wanted format is a parameter, or a default value that can be defined application-wide.
4. "Open folder" vs "Select folder". To be correct (at least in French), we don't open (ouvrir) a folder, but we select it in order to load or save file in it. Word 2019 uses "Changer le dossier" (Change folder), saying that we change where the files are. LibreOffice uses "Select folder".
5. FileDialogs_Up: Windows Explorer displays ""Up to" (jusqu'à) followed by the name of the folder. If you don't display the name of the folder, it's more correct to talk to "Parent folder" (dossier parent).
6. FileDialogs_MoveTo: it depends on the exact phrase. If you follow the text with the name of the folder, it is "Déplacer vers" (move to); if the folder name is not appended, it is "Déplacer" (move).
7. "KB" vs "kb" in English: I've already corrected this on my side.
8. "open folder" vs "select folder", event if you don't change the class name, you could change the resources. Another possibility would be to define a class alias, so both names are correct.
9. FileDialogs_InvalidOrMissingExtension: the name says "Invalid" or "Missing", but the text shows a warning, no something about an invalid or missing extension. If we change the extension, it is not always invalid. Why not name the resource ChangeExtensionConfirmation?