Error installing Reporting Server-- IIS / ASP.Net message

11 posts, 1 answers
  1. Larry
    Larry avatar
    3 posts
    Member since:
    Mar 2014

    Posted 15 Feb 2017 Link to this post

    I've just downloaded Telerik's reporting products and during the installation I've hit a problem with Report Server.  I'm running Windows 8, with IIS 10 express I believe and .Net 4.6

     

    At first the installer runs along fine, installing Telerik Reporting, but when it comes to Report Server it sort of stalls for about 10 minutes.  I've attached a couple of screenshots of what it looks like both before and after the error; unfortunately the forum software doesn't allow me to attach the error log itself (only images), so let me know if I can send it to you some other way.  Thanks for your help!

     

     

     

  2. Answer
    Stef
    Admin
    Stef avatar
    3610 posts

    Posted 16 Feb 2017 Link to this post

    Hi Larry,

    Please check the following:
    1. Run a browser window and type localhost - this is a test to check if the local IIS is started - Installing IIS. If it is not, you need to start it as Telerik Report Server is registered at port:83 during the installation.
    2. Check if the machine has .NET4.5 framework.

    You can use the MSI files downloadable from your Telerik account - Downloads - Report Server to install the product.


    Let us know how it goes and if you need further help.

    Regards,
    Stef
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Larry
    Larry avatar
    3 posts
    Member since:
    Mar 2014

    Posted 16 Feb 2017 in reply to Stef Link to this post

    Thanks Stef, I got it going.  

    For some reason http://localhost wasn't working, so reset IIS, and got past that bit.  

    One odd thing is before doing so I tried uninstalling Report Server, for a clean start, and was told an installation was already in progress (it wasn't, that I could see.)  I had to reboot before I could uninstall RS.  Once I did the reinstallation of RS went smoothly.

  4. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 17 Feb 2017 Link to this post

    Hi Larry,

    We will need to know the exact settings in order to run local tests.

    If I understand correctly the setup, you ran Telerik Control Panel until it stated that Telerik Report Server cannot be installed. Then you stopped the installer, downloaded the MSI and tested to run it, but the system returned that there was an ongoing installation process.

    Regards,
    Stef
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Larry
    Larry avatar
    3 posts
    Member since:
    Mar 2014

    Posted 17 Feb 2017 in reply to Stef Link to this post

    Hi Stef,

    The timeline you described sounds roughly correct.  The original install failed, so I tried the MSI, and that failed too-- but it didn't tell me another install was in progress.  That only happened when I tried to uninstall afterward.  

    There was nothing in the taskbar, and I didn't see anything in the windows task manager that would indicate something was running behind the scenes (I was looking for something with 'telerik' or 'report' in the name) so I rebooted, and was able to proceed.

     

  6. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 20 Feb 2017 Link to this post

    Hello Larry,

    There is a suggestion that Telerik Control Panel started installation of products' prerequisites (other products required by the selected for installation Telerik product).

    Some record about the installation may provide more details, please check if there are log files left in %programdata%/Telerik/Installer/Logs.

    Regards,
    Stef
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. Daniel
    Daniel avatar
    3 posts
    Member since:
    Nov 2017

    Posted 30 Nov 2017 Link to this post

    Hi,

    We are challeged by the same issue - we have downloaded the trial of Telerik Reporting server (running on a MS Server2016) and is unable to complete the installation as it states that either IIS og ASP.NET 4.5 is not installed/working. I can confirm that IIS is running and we have ASP.NET 4.6 installed. Kindly advice means to complete installation, thanks.

    Brdgs

    Daniel

  8. Daniel
    Daniel avatar
    3 posts
    Member since:
    Nov 2017

    Posted 30 Nov 2017 Link to this post

    scr.dump of error
  9. Daniel
    Daniel avatar
    3 posts
    Member since:
    Nov 2017

    Posted 30 Nov 2017 in reply to Daniel Link to this post

    Solved. I had to install two features (both addressing asp.net 4.6)
  10. Bill
    Bill avatar
    1 posts
    Member since:
    Jun 2020

    Posted 24 Jun 2020 in reply to Daniel Link to this post

    Can you be a little more specific how you solved this?  I am running into the same problem.
  11. Ivan Hristov
    Admin
    Ivan Hristov avatar
    236 posts

    Posted 29 Jun 2020 Link to this post

    Hello Bill,

    Internet Information Services need to have the .NET-related features checked in the Windows Features dialog box as shown below:

    Besides that, these features need to be registered. This is done with the tool aspnet_regiis.exe, which should be installed in the .NET Framework directory. For more information check this MSDN article: ASP.NET Integration with IIS 7.

    If you still have troubles installing Telerik Report Server, please open a support ticket and let us help you.

    Regards,
    Ivan Hristov
    Progress Telerik

    Progress is here for your business, like always. Read more about the measures we are taking to ensure business continuity and help fight the COVID-19 pandemic.
    Our thoughts here at Progress are with those affected by the outbreak.
Back to Top