This is a migrated thread and some comments may be shown as answers.

Error getting started with WPF RadGridView

3 Answers 86 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Kin
Top achievements
Rank 1
Kin asked on 22 Nov 2009, 08:44 PM
I just installed Q3 RadControls for WPF demo with VS2008 Pro on Windows 7.  I am attempting to follow along with

http://tv.telerik.com/wpf/radgridview/getting-started-with-radgridview-for-wpf

and am hitting an error immediately.  When I drag the RadGradView from the Toolbox onto the Design window, I receive a lengthy error dialog:

'Telerik.Windows.Controls.GridView;;;Component\Themes\GenericOfficeBlack.xaml' value cannot be assigned to property 'Source' of object 'System.Windows.ResourceDictionary'.  '/Teleric.Windows.Controls.GridView;component/themes/office/black/GridViewToggleButton.xaml' value cannot be assigned to property 'Source' of object 'System.Windows.ResourceDictionary'.
Object reference not set to an instance of an object.  Error at object 'System.Windows.ResourceDictionary' in markup file 'Telerik.Windows.Controls.GridView;;;Component\Themes\GenericOfficeBlack.xaml'.  Error at object 'System.Windows.ResourceDictionary'.

(This is a fresh install of VS 2008 Pro ... I haven't tried anything else with this config, and no other Telerik demos are presently installed.)

Any ideas what might be causing this?  Did I miss an install step of some kind? 

Thanks!

3 Answers, 1 is accepted

Sort by
0
Kin
Top achievements
Rank 1
answered on 22 Nov 2009, 10:44 PM
As followup ... I did manage to work around this.

Most controls seem to work just fine.  If I drag in a RadTileView, then follow that with a RadGridView, and then delete the RadTileView ... it all seems to work.  Don't know what the matter is ... but at least I can get it to go.

0
Marc-Andre
Top achievements
Rank 1
answered on 26 Nov 2009, 04:42 PM
Same here and I've been able to workaround the same way. I have another issue too. I can only use the RibbonControls on my Windows XP machine. I get an error when I try to add the Dlls on my Windows 7 computer.

Any ideas?
0
Valerio Giorgi
Top achievements
Rank 1
answered on 26 Nov 2009, 04:54 PM
Hi

I have the same problem:

In my debug\bin directory in the "IT"  folder i missing a dll  "Telerik.Windows.Controls.resources.dll"  i copied the dll and now DataGridView works fine
Tags
GridView
Asked by
Kin
Top achievements
Rank 1
Answers by
Kin
Top achievements
Rank 1
Marc-Andre
Top achievements
Rank 1
Valerio Giorgi
Top achievements
Rank 1
Share this question
or