This is a migrated thread and some comments may be shown as answers.

Edit a copy unavailable

15 Answers 183 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Missing User
Missing User asked on 18 Apr 2010, 06:27 PM
I was trying the new VS2010 with Blend 4 RC, Edit a copy is unavailable/grayed out. All styles under Edit additional styles are grayed out from Telerik components. Now I cannot edit RoyStyle and such, please help me.

15 Answers, 1 is accepted

Sort by
0
Missing User
answered on 20 Apr 2010, 03:33 PM
No one to the rescue?
0
Missing User
answered on 21 Apr 2010, 09:39 PM
Support is rubbish here :(
0
Kalin Milanov
Telerik team
answered on 22 Apr 2010, 09:21 AM
Hello Marcel,

We have found a way to reintroduce Edit c Copy in Blend and this fix will be available in an upcoming service pack roughly at the end of next month. It is possible however to have this fixed and available in a prior to that internal build.

Right now your only option is to drop a GridViewRow in Blend's design surface, edit its template by selecting from the menu Object -> Edit Style -> edit a Copy ...
Once done you can delete the GridViewRow you just dropped and apply the style to the RadGridView's RowStyle property.

I hope this will do until we get this Blend matter resolved.

Regards,
Kalin Milanov
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Missing User
answered on 22 Apr 2010, 06:27 PM
Just checked it but I don't see any of the settings here:
http://www.telerik.com/help/wpf/styling-radgridview-rows.html

Like:

Blend will update and will provide you the style properties for the style. In this case we will change the Background property to RowBackground and BorderBrush property to RowBorder.

And:

To do this from the menu select Object > Edit Other Styles > Edit RowStyle > Edit Style.

Doesn't even exists here.


I really need to edit the style since the default style doesn't match with the rest of the program. Any other idea's how to resolve this?





0
Kalin Milanov
Telerik team
answered on 23 Apr 2010, 11:37 AM
Hi Marcel Pietsen,

Please find attached a sample application which contains a RadGridView with attached row style and template to it so you can edit it to match your design.

Also you might want to check out this article, especially the Styling GridViewHeaderCell for another view on how to style control parts.

All the best,
Kalin Milanov
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
raven
Top achievements
Rank 1
answered on 21 Jul 2010, 08:52 PM
do you have a project sample for styling the header row? I dont have access to expression blend...

Thanks
0
Paul
Top achievements
Rank 1
answered on 31 Oct 2011, 07:05 PM
This is still not working!

Telerik Q2 2011
Expression Blend 4

Create empty is the only option.
0
Julien
Top achievements
Rank 1
answered on 29 Dec 2011, 11:20 AM
Hi there,

Problem is also available in version 2011.3.1214.40.

Could you check what is wrong ?

Thanks,

Regards,

Julien Dutto
0
Vanya Pavlova
Telerik team
answered on 29 Dec 2011, 11:26 AM
Hi,

 

Unfortunately we have some issues related to the Blend support for RadGridView/WPF. I'll recommend you to use the following approach:


1.Find in Assets library a single GridViewRow.
2.Drag it onto the Artboard, right click on it and choose the option Edit Template -> Edit a copy.

You may use the same approach for any other GridView part.


Kind regards,
Vanya Pavlova
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Julien
Top achievements
Rank 1
answered on 29 Dec 2011, 11:38 AM
Hi Vanya,

Thanks a lot for your answer. Do you have an estimated date when a fix could be provided for Blend support ? 
Indeed, it is quite problematic for our designer who doesn't have the full WPF knowledge and who is wasting a lot of time on style editing.

Thanks a lot,

Regards,

Julien.
0
Vanya Pavlova
Telerik team
answered on 29 Dec 2011, 11:44 AM
Hello,

 

We will do our best to provide a fix for this issue for the next official release.
Can you verify how the suggested workaround works for you? It is quite the same, however you should modify the styles element by element, not directly through the RadGridView and "Edit Additional Templates" option.  Indeed this is the only one diffference.
If you have any additional questions about styling Telerik RadControls/WPF do not hesitate to contact us! 


Greetings,
Vanya Pavlova
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Julien
Top achievements
Rank 1
answered on 29 Dec 2011, 11:51 AM
Hi Vanya,

Indeed, this way is working perfectly.

Do you know if this is a more general problem ? The "Edit a copy" option is unavailable for almost all the Rad controls we are using.

Thanks a lot for your responsiveness.

Regards,

Julien.
0
Vanya Pavlova
Telerik team
answered on 29 Dec 2011, 12:23 PM
Hi,

 

This sounds really strange. I have just tested the behavior you described however everything works fine by my side.
Please try the following one and let me know what happens:


1. Create a brand new WPF project in Blend. 
2. Manually add references to the controls you need to use. 
3. Drag a single RadButton or any other RadControl (not templated part of RadGridView) onto the ArtBoard, right click on it and choose the option Edit Template->Edit a copy. 


Kind regards,
Vanya Pavlova
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
May
Top achievements
Rank 1
answered on 29 May 2012, 11:18 AM
I want to change the BorderBrush for the background property for the "PART_RowBorder" border in the gridrow controltemplate. I know I can take edit the controltemplate but I find it a bit excessive to take out the whole template when i only need to edit one brush in the intire template. Can I solve this from the style?
I hope you can answer this and that there is a solution, because I need to do a lot of flickering on the default style, but I don't want to do massive changes them.
0
Vanya Pavlova
Telerik team
answered on 29 May 2012, 11:38 AM
Hello May,

 

The logic behind the grid lines is internally incorporated within the templates of GridViewRow (horizontal)/GridViewCell(vertical). There is no way to modify properties such as BorderBrush/BorderThickness using a simple style. If you want to modify either the horizontal/vertical gridlines and their thickness you should predefine the templates of GridViewRow/GridViewCell.
In addition to this you may also use the properties of RadGridView HorizontalGridLinesBrush/VerticalGridLinesBrush: 

<telerik:RadGridView  ItemsSource="{Binding Path=Items}" HorizontalGridLinesBrush="Red" VerticalGridLinesBrush="Blue" />




Greetings,
Vanya Pavlova
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Tags
GridView
Asked by
Missing User
Answers by
Missing User
Kalin Milanov
Telerik team
raven
Top achievements
Rank 1
Paul
Top achievements
Rank 1
Julien
Top achievements
Rank 1
Vanya Pavlova
Telerik team
May
Top achievements
Rank 1
Share this question
or