This is a migrated thread and some comments may be shown as answers.

Drilldown Action Not working as expected

2 Answers 95 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Chuck Harrington
Top achievements
Rank 1
Chuck Harrington asked on 31 Jan 2011, 11:24 PM
I have read through the documentation and viewed the Telerik TV video on Drilldown Action, but cannot get it to work like I need.  I have a report with a parent group of Employee Team Names and a child group containing the employees in each of the teams.  The parent group has just the team name and has no action.  The employee group has the employee name, which has the toggle visibility action set.  There is also a couple of other fields of data for each employee in this group level but they do not have any action set.  Finally I have a detail section containing  detail data I want to display for each employee when I expand the icon on the employee name.  The edit toggle target for the employee name action is the detail section name and the "expand" check box is unchecked.  What I expected was a report that listed each team name and the employee in that team with an unexpanded icon next to each employee name, however what I get when I preview the report is all of the detail section data for each employee already expanded.  I can click on the icon and hide the detail data, but what I want when the report is generated is the exact opposite.  The visible properties for each field is the detail section is obviously set to true.  I have tried different combinations but nothing gives me what I want.  I hope this somewhat lengthy explanation of the situation is clear.  Thanks in advance.

2 Answers, 1 is accepted

Sort by
0
Noreida
Top achievements
Rank 1
answered on 01 Feb 2011, 07:19 PM
You can set the Visible property of the detail section to true.
0
Chuck Harrington
Top achievements
Rank 1
answered on 01 Feb 2011, 08:26 PM
Noreida

A big shout out for you.  I went back to my report and the visibility property for the detail section, which was set to true, so I set it to false however I kept the visible property for each field in the detail section set to true.  That was the answer.  Now when I generate the report, it works like I want.
Thank you.
Tags
General Discussions
Asked by
Chuck Harrington
Top achievements
Rank 1
Answers by
Noreida
Top achievements
Rank 1
Chuck Harrington
Top achievements
Rank 1
Share this question
or