This is a migrated thread and some comments may be shown as answers.

Doesn't display window "add-new-record" when expand an existing parent row

4 Answers 18 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Alice
Top achievements
Rank 1
Alice asked on 13 Sep 2018, 11:13 AM

Hi, Dear Telerik!

I migrated to a new version of Kendo UI Grid MVC for using scroll and had issue.

I'm using a hierarchical view with WebApi and with editing rows. And when wont to add a new record to  row on parents table (clicked "add new record" in the table), can't do this. "Circle of loading" starting turn and turns endlessly. 

But when added record to a parent table and in this time added a new record to a table - this works correctly!

wrong? Also, when used old version Kendo UI (2016) this option was ok. But must migrate for a new version.

Can u help me? 

Regards, Andrey.

My index.cshtml

4 Answers, 1 is accepted

Sort by
0
Alex Hajigeorgieva
Telerik team
answered on 17 Sep 2018, 12:23 PM
Hello, Andrey,

I created a simple Dojo with a similar configuration that I see in the pasted snippet here:

- a master grid with in-cell editing and endless scrolling
- a child grid with Inline editing and virtual scrolling.

The child grid has a toolbar button which adds a new line to the child grid when pressed. This is the expected behaviour for inline editing:

https://dojo.telerik.com/@bubblemaster/eFiCUGaR

On the other hand, there seem s to be an edit event handler which checks if the added record is new before proceeding. If the record has no Id or if the Id has the default value, this custom logic gets executed:

if (!hidden) {
       $('#kendoGrid').css('overflow: auto');
   } else {
       $('#kendoGrid').css('');
   }

So that I can help you figure out how to solve the issue, could you check the example I sent, modify it accordingly and let me know how to reproduce this locally.

Regards,
Alex Hajigeorgieva
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
0
Alice
Top achievements
Rank 1
answered on 18 Sep 2018, 12:37 PM
Hava a nice day, Alex Hajigeorgieva. 

I already find a resolve.  The core issue was in scrolling function in subgrid.
And when scrolling is true, I see a empty space in subgrid if data is null, the count of rows is less than the subgrids window size.
So, I removed this scroll and grid will work ok! But i dont know why this feature crashed "add new record" function.
But Your Dojo works correctly.
What You think about this? 

I will investigate further this issue, and will write my throughts.

Thanks,
Andrey.
0
Alice
Top achievements
Rank 1
answered on 18 Sep 2018, 01:37 PM

"Core issue was in virtual (!) scrolling"

(With other scrolling is work)

 

And can You delete, please, "code block" in my first message. (It's realy important for me)

Thank you, Andrey.

0
Alex Hajigeorgieva
Telerik team
answered on 20 Sep 2018, 12:36 PM
Hi, Andrey,

I have deleted the code snippet as requested. I am glad that you found a solution that works for you.

Let me know if you wish to investigate the behaviour further.

Kind Regards,
Alex Hajigeorgieva
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Grid
Asked by
Alice
Top achievements
Rank 1
Answers by
Alex Hajigeorgieva
Telerik team
Alice
Top achievements
Rank 1
Share this question
or