This is a migrated thread and some comments may be shown as answers.

DNN Web.Config Incomplete

1 Answer 19 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
David House
Top achievements
Rank 2
David House asked on 06 May 2010, 11:41 PM
When we install a tested module to a second site (not the development site) the Telerik Web Viewer does not register correctly on the new site and it cannot be accessed. Scripting errors occur because the object is missing.

Here is what is included in the DNN manifest file and isntalled on the site:

Module containing the Viewer control. (both ASCX and ASCX.VB files)
The following DLL's aree installed into the \bin folder:

Telerik.Reporting.dll

Telerik.ReportViewer.WebForms.dll

Telerik.Web.UI.dll

WebReports.dll


The installation package executes correctly and places all of the files into their respective locations. The report selector module can be added to a tab, but the viewer will not display and the system generates scripting error when trying to build the default.aspx page that holds the viewer.

What are we missing?

thanks...

1 Answer, 1 is accepted

Sort by
0
David House
Top achievements
Rank 2
answered on 07 May 2010, 03:05 AM
Once we included the Telerik.Reporting.XamlRendering.dll in the package, it works as expected.

No reference of it in the development environment, but I found a note in one of the threads about moving from Dev to Production.

Closed...
Tags
General Discussions
Asked by
David House
Top achievements
Rank 2
Answers by
David House
Top achievements
Rank 2
Share this question
or