Dead in the water after update to Q2

4 posts, 1 answers
  1. James
    James avatar
    7 posts
    Member since:
    Mar 2011

    Posted 17 Jul 2011 Link to this post

    Since updating to the Q2 2011 version just recently, I find that none of my applications that uses the Tererik controls work, nor can I create a new app and add Telerik controls to it.

    Here is a simplified Test Case:
    I created a fresh WPF application project, opened the MainWindow.xaml, and tried to drag a RadMenu onto it.
    It throws up this Error Dialog:

    Set property 'System.Windows.ResourceDictionary.Source' threw an

    "Cannot locate resource 'themes/genericmetro.xaml'."


    I'd like to know how the Telerik RadControls for WPF installation works, so that I can understand a bit of what's going on. The installation folder, in C:\Program Files (x86)\Telerik, has a folder that would seem to be an older version: RadControls for WPF Q3 2010 SP1\Binaries\WPF\and so on.

    Within AppData\Roaming\Telerik, I see an Updates folder with various folders for hotfixes. And the csproj file contains hintPaths that point to these. So, clearly the hintPaths are trying to redirect VS to find the latest versions of our assemblies. Is this the mechanism that is not working here?  Would it help to just un-install Telerik, and reinstall something that is the latest version with the hotfixes already rolled into it?

    Thank you for your help,

    James W. Hurst


    IDE:              Visual Studio 2010 Ult SP1
    Operating System: Windows 7 Ult x64
    Telerik Product:  RadControls for WPF, v.2011.2.712.40
    Other Products:   JetBrains ReSharper
  2. Answer
    Konstantina avatar
    2332 posts

    Posted 19 Jul 2011 Link to this post

    Hi James,

    Have you tried to remove the old installation, clean the GAC and if this does not help could you try to move away the design dlls from the installation folder. Don't delete them just move them to your desktop for example, close and open the studio and if this does not fix your problem move them back.

    Best wishes,
    the Telerik team

    Register for the Q2 2011 What's New Webinar Week. Mark your calendar for the week starting July 18th and book your seat for a walk through of all the exciting stuff we will ship with the new release!

  3. Rayne
    Rayne avatar
    261 posts
    Member since:
    Sep 2010

    Posted 27 Oct 2011 Link to this post

    I need help with this as well. But I'm not sure I understand the suggestion.

    I have installed RadControls for WPF Q1 2011. Then inside of VS I've downloaded several updates, including Q2. The dlls used in my application are located inside of a folder within my solution folder, so that they are can be checked into TFS. All my projects in my solution reference the dlls in the solution folder.
    Earlier today I updated and got the most recent update via the extension. Today, when I try to work on my project I keep getting this error about the genericmetro.xaml.

    I'm not sure how to fix it. Do I need to uninstall the initial RadControls and reinstall the latest version using the msi installer?
  4. Konstantina
    Konstantina avatar
    2332 posts

    Posted 28 Oct 2011 Link to this post

    Hi Rayne,

    You can find more information how to upgrade your project with the latest assemblies in this help article.
    Please go through it and let us know if you still experience difficulties.

    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>
Back to Top