This is a migrated thread and some comments may be shown as answers.
Date problem with Excel Export in XP
9 Answers 42 Views
This is a migrated thread and some comments may be shown as answers.
Shuja
Top achievements
Rank 1
Shuja asked on 20 Nov 2014, 04:21 PM
I'm added an Excel export option to a grid, which features multiple date columns.

Under Windows 7, IE 11 and Chrome export this data to Excel with no problem, dates appear correctly.

However when trying it from two different Windows XP machines both IE and Chrome export date fields as just the year value (e.g. 2011), which is then formatted as a date, showing a value such as 03/07/1905.

Unfortunately, many of our users are still using XP - is there a solution?

9 Answers, 1 is accepted

Sort by
0
Atanas Korchev
Telerik team
answered on 20 Nov 2014, 04:34 PM
Hello Shuja,

Other users have reported problems with dates in older versions of Excel (2007). We will investigate the problem and update this thread once there is progress.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Atanas Korchev
Telerik team
answered on 25 Nov 2014, 09:35 AM
Hi,

We reproduced the problem and a fix will be available in the next internal build due by the end of the week.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Shuja
Top achievements
Rank 1
answered on 25 Nov 2014, 04:19 PM
Thanks, I'll try it then.
0
Robert
Top achievements
Rank 1
answered on 28 Dec 2014, 09:55 PM
I'm running into the same issue with Dates when exporting to Excel 2007. Is there a work around?

Thanks
Bob Turner
0
Atanas Korchev
Telerik team
answered on 29 Dec 2014, 09:18 AM
Hi,

The suggested workaround is to install the latest internal build.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Bob
Top achievements
Rank 1
answered on 14 May 2015, 01:20 PM
Has a fix for this been officially released (not an internal build)?
0
Atanas Korchev
Telerik team
answered on 15 May 2015, 06:14 AM
Hello Bob,

Yes, this bug is addressed in the latest official release.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
0
Bob
Top achievements
Rank 1
answered on 15 May 2015, 12:50 PM

We are on DLL version 2015.1.318.545.  Is the bug fixed in this version?

One of our users (off-site) sent us an example of this bug from our production site just the other day.  We have no way to reproduce as we don't have Excel 2007.

0
Atanas Korchev
Telerik team
answered on 19 May 2015, 05:44 AM
Hi Bob,

Yes, the bug is fixed in that version. Make sure the Kendo UI JS files are the same version.

Regards,
Atanas Korchev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
Tags
Grid
Asked by
Shuja
Top achievements
Rank 1
Answers by
Atanas Korchev
Telerik team
Shuja
Top achievements
Rank 1
Robert
Top achievements
Rank 1
Bob
Top achievements
Rank 1
Share this question
or