This is a migrated thread and some comments may be shown as answers.

Configuring IIS 8.0 to use Telerik.ReportViewer.WebForms

1 Answer 159 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jeff
Top achievements
Rank 1
Jeff asked on 27 Aug 2013, 05:27 PM
Hello everyone,
I'm sure this is an issue with my IIS 8.0 configuration but I haven't been able to work around it.  I can run my web app and generate reports from Visual Studio with no problems but I'm having problems with the reporting component (version 7.1.13.802) 
under IIS 8.0.   I started with a clean install of IIS and I am using the Default App Pool (.Net V4.0 Integrated) using the ApplicationPoolIdentity.   I have added permissions to my apps bin folder where the Telerik.ReportViewer.WebForms.dll are located and my web app functions except for displaying reports.   I get the following error:

The http handler needed by the Report Viewer has not been registered in the application's web.config file.  Add <add name="Telerik.ReportViewer.axd_*" path="Telerik.ReportViewer.axd" verb="*" type ="Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=7.1.13.802, Culture=neutral, PublicKeyToken=a9d7983dfcc261be" preCondition="integratedMode"/> to the system.webServer/handlers section of the configuration file.


Of course, this handler is already set up in my web.config file.   I believe this is a permission issue since I can change the Default App Pool to run under my user id and it does function correctly.    I am running IIS on my machine so I can make any adjustments that I need; however, I'd like to run this using the ApplicationPoolIdentity user because that is what I will likely have to use when it goes into production.  I know that this should work under Medium Trust (allthough Full Trust would be better).  I've tried to configure that but I'm not sure if I have been successful or not.  My root web.config file contains the following:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.web>
      <securityPolicy>
        <trustLevel name="Full" policyFile="internal"/>
        <trustLevel name="High" policyFile="web_hightrust.config"/>
        <trustLevel name="Medium" policyFile="web_mediumtrust.config"/>
        <trustLevel name="Low" policyFile="web_lowtrust.config"/>
        <trustLevel name="Minimal" policyFile="web_minimaltrust.config"/>
      </securityPolicy>
      <trust level="Full" originUrl=""/>
    </system.web>
</configuration>

Any suggestions as to what I'm missing in my configuration ?   

Thanks in advance -- Jeff Gaiche

1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 30 Aug 2013, 11:33 AM
Hi Jeff,

Using Integrated mode you need to register handlers in the system.webServer section of your web configuration. for more details take a look at the following articles:

I hope this helps.

Regards,
Stef
Telerik

Have you tried the new visualization options in Telerik Reporting Q2 2013? You can get them from your account.

Tags
General Discussions
Asked by
Jeff
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or