Chrome Print Error

7 posts, 0 answers
  1. usus
    usus avatar
    3 posts
    Member since:
    Nov 2005

    Posted 30 Sep 2019 Link to this post

    Hi Telerik,

    When i press the print button on report viewer (we are not using HTML5 report viewer)

    we began to recive the following error on chrome console.

    And pdf print page is not opening. 

     

    ERROR:

    Resource interpreted as Document but transferred with MIME type application/pdf: "http://192.168.0.52/Telerik.ReportViewer.axd?instanceID=6bda0c2faa75444b8a9ded052f8bbaa3&optype=Print&format=PDF&pageIndex=0&rand=1569851505961"

    Before one weeks ago everything was fine, print button was working correctly.

    we use report viewer Version=11.1.17.614

     

    Best Regards

    Ünsal

  2. Eli
    Eli avatar
    23 posts
    Member since:
    Mar 2011

    Posted 01 Oct 2019 in reply to usus Link to this post

    We are experiencing the exact same issue.  This happens when using Chrome, IE works. Web Forms report viewer 13.0.19.116
  3. Neli
    Admin
    Neli avatar
    233 posts

    Posted 01 Oct 2019 Link to this post

    Hi Ünsal,

    We are aware of the issue concerning Chrome. You can find information about the issue, solution and the possible workarounds in Print dialog doesn't open in Google Chrome 77.0.3865.75 KB article. Note that if you are applying the Workaround for the HTML5-based Report Viewers, after each update of Telerik Reporting, the js files will be overwritten. This means that you need to implement the workaround again.

    Let me know if you have any additional questions.

    Regards,

    Author nickname

    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. usus
    usus avatar
    3 posts
    Member since:
    Nov 2005

    Posted 03 Oct 2019 Link to this post

    I added the the defined script as explained in the suggested link (Workaround for the obsolete ASP.NET Web Forms Report Viewer), and it is working now.

    Thanks in advace.

    Best regards

  5. mateus
    mateus avatar
    2 posts
    Member since:
    Jan 2020

    Posted 10 Jan Link to this post

    I already inserted this JS code and it doesn't work in one relationship, but in another it works
  6. Neli
    Admin
    Neli avatar
    233 posts

    Posted 15 Jan Link to this post

    Hi mateus,

    Which report viewer do you use and are there any errors in the console of the browser? Note that in version 13.2.19.1213 (Internal build) we added improved print behavior for the obsolete ASP.NET Web Forms Report Viewer which allows printing again.

    Regards,
    Neli
    Progress Telerik

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. mateus
    mateus avatar
    2 posts
    Member since:
    Jan 2020

    Posted 15 Jan in reply to Neli Link to this post

    Hi Neli,

    I was setting the report to visible false and after one click I set it to true. For some reason he lost his data. I changed to display none and block and now it's working.

    Thank's!

Back to Top