This is a migrated thread and some comments may be shown as answers.

CheckBoxColumn not showing correct state when AutoGenerateColumns="False"

2 Answers 34 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Erik
Top achievements
Rank 1
Erik asked on 21 Feb 2012, 07:25 PM
I have a RadGrid with a CheckBoxColumn and AutoGenerateColumns="False". When I check a checkbox in the CheckBoxColumn and press Tab, the CheckBox shows the unchecked state. When I next press Shift-Tab to place focus back in the cell, the CheckBox shows the checked state.

Very simple code:
<telerik:RadGridView
    ItemsSource="{Binding MyCv}"
    AutoGenerateColumns="False">
    <telerik:RadGridView.Columns>
        <telerik:GridViewCheckBoxColumn
            DataMemberBinding="{Binding MyBool}"/>
    </telerik:RadGridView.Columns>
</telerik:RadGridView>

If I use autogenerated columns, the checkbox always shows the correct state. Am I doing something wrong or is this a bug?

I'm using the 2012 Q1 version

2 Answers, 1 is accepted

Sort by
0
Accepted
Vera
Telerik team
answered on 22 Feb 2012, 10:02 AM
Hello Erik,

 
Actually, this issue has already been resolved and the fix for it is part of our Latest Internal Build (version 2012.1.221). May I ask you to download it and see how it works on your side?

Let me know if you need any further assistance.

Greetings,
Vera
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Erik
Top achievements
Rank 1
answered on 22 Feb 2012, 07:10 PM
Thanks, new build fixes the issue :)
Tags
GridView
Asked by
Erik
Top achievements
Rank 1
Answers by
Vera
Telerik team
Erik
Top achievements
Rank 1
Share this question
or