This is a migrated thread and some comments may be shown as answers.

changed symbol is disappeared when creating or deleting new row

1 Answer 17 Views
Grid
This is a migrated thread and some comments may be shown as answers.
rafi
Top achievements
Rank 1
rafi asked on 01 May 2014, 11:07 AM
hi,

i use grid on batch mode and i have a problem with the grid presentation when editing the grid.

The problem occurs when i create or remove another row while other fields are in changed mode and have the changed symbol (orange little triangle),
in this scenario, the  symbol is disappeared from the rows that were changed, although the changes has not been saved! .

This problem exists also in the demo grid on: 
http://demos.telerik.com/kendo-ui/web/grid/editing.html

To reproduce the problem:

1. Change one cell in the grid.
2. Move to other field and notice that the orange triangle appears.
3. Press on "Add new record" .
4. The orange symbol is disappeared !

can you advice how to solve the problem?

thanks,
Mali








1 Answer, 1 is accepted

Sort by
0
Accepted
Petur Subev
Telerik team
answered on 05 May 2014, 07:06 AM
Hello Rafi,

Indeed redrawing the Grid removes the dirty state indicator, since the model does not hold information which column was changed (information is lost after redrawing the Grid). The same question is discussed in the following thread:

http://www.telerik.com/forums/losing-dirty-flag-on-edited-items-when-i-click-add-new-item

There is also link for a work-around that you can use.

Kind Regards,
Petur Subev
Telerik
 
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
 
Tags
Grid
Asked by
rafi
Top achievements
Rank 1
Answers by
Petur Subev
Telerik team
Share this question
or