This is a migrated thread and some comments may be shown as answers.

Cannot Find Connection String with Entity Framework

1 Answer 34 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Craig
Top achievements
Rank 1
Craig asked on 28 Aug 2013, 05:19 PM
Hi there,

First let me preface this that I using Telerik Reporting Q2 2013 Internal Build v7.1.13.726.
When I try to instantiate run my report against an object data source that is tied to a repository pattern that is backed by code-first entity framework (which is the closest I've come to getting this to work) I receive this error. Any ideas where I should look to solve this error.
My app.config in the reporting project has the correct connection string defined for the DbContext so I'm a little confused.



1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 02 Sep 2013, 12:47 PM
Hi Craig,

Please take a look at the following blog article about the new DbContext support: Try out new Entity Framework Support in Telerik Reporting and Earn Rewards, and the EntityDataSource Wizard help article. At step 1 in the help article using code-first approach you need to set the same connection string as the one used to create the models.

I hope this helps.

Regards,
Stef
Telerik

Have you tried the new visualization options in Telerik Reporting Q2 2013? You can get them from your account.

Tags
General Discussions
Asked by
Craig
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or