This is a migrated thread and some comments may be shown as answers.

Cannot edit cell in radgridview if data source is data table with numeric column name

4 Answers 105 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Andy
Top achievements
Rank 1
Andy asked on 22 Mar 2012, 04:55 AM
Hi Telerik Team,

I tried to bind my radgridview with a DataTable contains year series DataColumns (I set autogeneratecolumn="true"). It can display the value but I can't edit the value if the column header contain only number. (please check attached image). 

Is it a known bug or I just need to enable any property in radgridview? please advise.

Thanks,
Andy

4 Answers, 1 is accepted

Sort by
0
Dimitrina
Telerik team
answered on 22 Mar 2012, 07:48 AM
Hello Andy,

 Would you please bind the RadGridView to the DefaultView of the DataTable?

Regards,
Didie
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Andy
Top achievements
Rank 1
answered on 23 Mar 2012, 06:14 AM
Hi Didie,

Thanks, It works. But I got other issue if I use DefaultView of DataTable as ItemsSource.
Fyi, I use GroupDescriptor to group the data and every time after I edit value from a cell, the cell's row will be moving to the bottom of the group.  This didn't happen when I bind it to DataTable. How do i fix this?

Thanks,
Andy
0
Andy
Top achievements
Rank 1
answered on 28 Mar 2012, 04:36 AM
Hi Didie,

Do you have a solution on this issue? I attached the screenshot of the gridview for better understanding.
Before I edit the cell, the row sequence is correct but after I edit the cell, it seems like it performs sorting based on last edited cell.
I want to make the row stay at its original index. is there any way to disable this sorting after editing a cell?

Cheers,
Andy
0
Andy
Top achievements
Rank 1
answered on 03 Apr 2012, 07:06 AM
Anyone had the same issue and managed to solve this before? please help.

This only happens when I use record grouping and use dataview as itemssource for radgridview.
upon cell_validated event. updated row will be repositioned to the bottom of the group. any idea to disable it?

Cheers,
Andy
Tags
GridView
Asked by
Andy
Top achievements
Rank 1
Answers by
Dimitrina
Telerik team
Andy
Top achievements
Rank 1
Share this question
or