This is a migrated thread and some comments may be shown as answers.

cannot be opened because it is version 655

1 Answer 26 Views
Grid
This is a migrated thread and some comments may be shown as answers.
TomLarry
Top achievements
Rank 1
TomLarry asked on 01 Sep 2015, 02:11 PM

The database 'C:\PROGRAM FILES (X86)\TELERIK\UI FOR ASP.NET AJAX Q2 2015\LIVE DEMOS\APP_DATA\TELERIK.MDF' cannot be opened because it is version 655. This server supports version 612 and earlier. A downgrade path is not supported.
Could not open new database 'C:\PROGRAM FILES (X86)\TELERIK\UI FOR ASP.NET AJAX Q2 2015\LIVE DEMOS\APP_DATA\TELERIK.MDF'. CREATE DATABASE is aborted.

There are a few post on this but no actual solution.

File .mdf is confirmed exists in the location

The following SQL are confirmed installed:

- MS SqL Server 2014 Express LocalDB

- MS SQL Server 2012 Express LocalDB

- MS SQL Server 2005

- MS SQL Server 2008 (64-bit)

 

1 Answer, 1 is accepted

Sort by
0
Marin Bratanov
Telerik team
answered on 02 Sep 2015, 07:20 AM

Hello,

The error indicates that the SQL server that is used to open the database is an old version (most likely the MS SQL Server 2005 one - it probably matches the default name we have in out examples).

You need to ensure that the correct SQL server instance is used. To do that, open the web.config file and edit the connection strings so they use the instance names from your machine (e.g., the name of the MS SQL Server 2008 instance).

Regards,

Marin Bratanov
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Grid
Asked by
TomLarry
Top achievements
Rank 1
Answers by
Marin Bratanov
Telerik team
Share this question
or