This is a migrated thread and some comments may be shown as answers.

Cannot Add ReportViewer

2 Answers 41 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Kadir Kilicoglu
Top achievements
Rank 1
Kadir Kilicoglu asked on 20 Sep 2010, 07:03 PM
I have searched through Telerik KB, Forums etc. and also Google. Yes, it is about the infamous "Operation could not be completed" error.

Most of the threads about the issue includes formatetc error too but in my case it is not true. I am just getting an "Operation could not be completed" error.

Here is the scenario:
  • Windows Vista with all updates
  • VS 2008
  • Telerik RadControls for ASP .NET AJAX Q3 2009 .Net 3.5
I have completed a web project within this environment. But I needed a reporting tool so I installed Telerik Reporting Q1 2009. I have developed a Class Library and tested my newly created reports. Everything was fine until I tried to add a ReporView into one of my web pages. I got "the" error.

To solve the problem (as suggested):
  • Re-Install Telerik Reporting
  • Reset Tool Box
  • Clean Asp .Net Cache
  • Restart VS/Computer
  • Add a couple of lines to web.config

Still the same.

Please, can anyone suggest something?

2 Answers, 1 is accepted

Sort by
0
Accepted
Steve
Telerik team
answered on 21 Sep 2010, 04:40 PM
Hi Kadir Kilicoglu,

We've been reported this error a couple of times only with older versions of the product and the steps you've listed usually fixed the problem. Q1 2009 is more than an year old now and we recommend that you install the latest version (Q2 2010) and let us know of the outcome. If the problem persists, try repairing Visual Studio.

Regards,
Steve
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Kadir Kilicoglu
Top achievements
Rank 1
answered on 22 Sep 2010, 02:29 PM
For sure the problem was not with Telerik Reporting but Visual Studio..

Now I have created a new solution and created all projects from groun and everything is working fine.

Thanks for your help and lets pray that VS would not "joke" me with another weird problem.
Tags
General Discussions
Asked by
Kadir Kilicoglu
Top achievements
Rank 1
Answers by
Steve
Telerik team
Kadir Kilicoglu
Top achievements
Rank 1
Share this question
or