Candlestick chart not "zoomed" in

3 posts, 1 answers
  1. Dragan
    Dragan avatar
    8 posts
    Member since:
    Oct 2013

    Posted 05 Feb 2015 Link to this post

    Hi,

    we're having trouble rendering nice Candlestick chart in some cases.

    Specifically, for some values passed, chart is not "zoomed" in to better see difference between points but rendered from the '0' on value axis instead. For other cases, it's behaving as expected. To better illustrate, please see following dojo: http://dojo.telerik.com/AnOhe and see that value axis starts from '0' where it could start from '18' for example.

    Is there a way to force chart to do this, instead of calculating valueAxis.max and valueAxis.min manually?

    Thanks,

    Dragan
  2. Answer
    T. Tsonev
    Admin
    T. Tsonev avatar
    2817 posts

    Posted 09 Feb 2015 Link to this post

    Hello,

    The value axis can be forced into a "narrow" mode in which it will not automatically expand to show zero.
    This is controlled via the narrowRange property.
    valueAxis: {
        narrowRange: true
    }


    I've updated the snippet to include this setting.
    I hope this helps.

    Regards,
    T. Tsonev
    Telerik
     
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
     
  3. Dragan
    Dragan avatar
    8 posts
    Member since:
    Oct 2013

    Posted 10 Feb 2015 Link to this post

    Hi,

    thanks a lot, this is it.
Back to Top