This is a migrated thread and some comments may be shown as answers.

Can I Disable Horizontal Scrollbar?

10 Answers 378 Views
PanelBar
This is a migrated thread and some comments may be shown as answers.
Ryan
Top achievements
Rank 1
Ryan asked on 01 Mar 2010, 11:50 AM
Is it possible to disable the horizontal scrollbar? If yes how do I do this?
(RadPanelBar is bound to a HierarchicalDataTemplate).

10 Answers, 1 is accepted

Sort by
0
Kiril Stanoev
Telerik team
answered on 01 Mar 2010, 02:16 PM
Hi Ryan,

You can use the attached ScrollViewer property:

<telerikNavigation:RadPanelBar x:Name="panelBar1"
                ItemTemplate="{StaticResource MyHierarchicalItemTemplate}"
                ScrollViewer.HorizontalScrollBarVisibility="Disabled" />

Let me know how this works for you.

All the best,
Kiril Stanoev
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Ryan
Top achievements
Rank 1
answered on 04 Mar 2010, 12:21 PM
Hi Kiril

I'm afraid this did not work.

I'm looking at the properties of the ScrollViewer at runtime using Snoop and HorizontalScrollBarVisibility is set to Auto.
0
Kiril Stanoev
Telerik team
answered on 05 Mar 2010, 10:58 AM
Hi Ryan,

Unfortunately I was not able to reproduce the issue. Please find attached my sample project. Could you please have a look at it and let me know if I am missing something. Also, if you manage to reproduce the issue, could you please let me know the exact steps. I'd be glad to further assist you.

Sincerely yours,
Kiril Stanoev
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Peter Chapman
Top achievements
Rank 1
answered on 17 Aug 2010, 05:54 PM
I've got this problem too. I agree the sample project works. It's not so happy in real world scenarios though.

Here's what happens to me:

1) in blend, select the RadPanelBar, set the horizontal and vertical scroll bar visibility to 'disabled'
2) see that blend has updated the xaml correctly.
3) click off the control, and back on to it.
4) see that the properties inspector shows the values as 'Auto' even though the xaml still shows 'disabled'

... and snoop shows the values as 'Auto' at runtime.

Hope this helps.

Pete
0
Peter Chapman
Top achievements
Rank 1
answered on 17 Aug 2010, 06:04 PM
If anybody cares, i've got round this limitation by removing the ScrollViewer from the RadPanelBar by defining a template and removing it explicitly. Notably, setting the visibility of the scroll bars on the ScrollViewer in the template directly also had no effect.

ta 
0
Tina Stancheva
Telerik team
answered on 20 Aug 2010, 02:44 PM
Hello gyus,

We still can't reproduce this issue. Therefore I wanted to ask you what is the version of the RadControls you are using and also what is the version of Blend?

Thank you in advance.

Kind regards,
Tina Stancheva
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Tina Stancheva
Telerik team
answered on 20 Aug 2010, 02:45 PM
Hello guys,

We still can't reproduce this issue. Therefore I wanted to ask you what is the version of the RadControls you are using and also what is the version of Blend?

Thank you in advance.

Kind regards,
Tina Stancheva
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Peter Chapman
Top achievements
Rank 1
answered on 20 Aug 2010, 02:59 PM
Hi,

I am using 3.0.1927 of blend, and the telerik dll's are reporting 2010.1.422.35.

ta
0
Tina Stancheva
Telerik team
answered on 25 Aug 2010, 12:32 PM
Hi Peter Chapman,

Can you please take a look at this video and let me know if I am missing something?

Thank you in advance.

Best wishes,
Tina Stancheva
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Peter Chapman
Top achievements
Rank 1
answered on 26 Aug 2010, 09:55 AM
Hi Tina,

Thanks for the video. It does show a sample where the control is working correctly.

Real world use of this control is pretty far away from your simple example, and there may have been any number of other factors. If memory serves, my use was a rad panel nested inside a rad panel, in a rad expander. The inner rad panel was bound to a set of hierarchical data templates which I varied using a template selector. The Xaml was all specified in resource dictionaries, and I would have had both visual studio and blend open at the same time. 

The problem did exist at runtime though, which leads me away from thinking it was a problem with the IDE. Snoop told me the values for the scrollbar visibility actually being applied were different to those in the Xaml.

My code has moved on quite a long way and and I've not got time to roll it back to the exact scenario. I  am aware how unhelpful this is as a bug report! I'm happy for you to leave this, and if I find it happening again I will try to provide more information.

thanks
Pete
Tags
PanelBar
Asked by
Ryan
Top achievements
Rank 1
Answers by
Kiril Stanoev
Telerik team
Ryan
Top achievements
Rank 1
Peter Chapman
Top achievements
Rank 1
Tina Stancheva
Telerik team
Share this question
or