This is a migrated thread and some comments may be shown as answers.

Bold and italic issue using Myriad pro font in the report

2 Answers 105 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Abhishek
Top achievements
Rank 1
Abhishek asked on 31 Aug 2017, 12:27 PM

Hello , 

I am using Myriad pro font in the report. There is no difference in the regular, bold and italic text of the generated Pdf report. It works fine when changed to Arial font. I have the font installed and embedded in the pdf. Is there anything specific that needs to be done for bold and italic to show up in the report ?

2 Answers, 1 is accepted

Sort by
0
Abhishek
Top achievements
Rank 1
answered on 02 Sep 2017, 05:18 PM
Anybody has faced this issue earlier ?
0
Katia
Telerik team
answered on 04 Sep 2017, 12:30 PM
Hi Abhishek,

The used font must have support for the specified styling like bold, italic etc. The image rendering (Report Designer preview) will show the content styled as it draws it. 
Still the PDF rendering that uses native PDF objects will not be able to found the corresponding font variation in the installed on the machine fonts and it will use other fallback variation of the font.

Thus, you need to check if Myriad Pro Bold and Myriad Pro Italic font variations are installed on the machine. If the Fonts folder contains only Myriad Pro Regular, consider installing those fonts variations or using a different font family.

For more details about displaying fonts in PDF documents check Font Requirements.

I hope this will help.


Regards,
Katia
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
General Discussions
Asked by
Abhishek
Top achievements
Rank 1
Answers by
Abhishek
Top achievements
Rank 1
Katia
Telerik team
Share this question
or