A generic error occurred in GDI+.

4 posts, 0 answers
  1. Nick
    Nick avatar
    6 posts
    Member since:
    Feb 2015

    Posted 09 Feb 2017 Link to this post

    I have a report that has a subreport. If I set the subreport to Visible = false, everything works fine. If I have the subreport visible, it errors with "Internal Server Error A generic error occurred in GDI+." The subreport just contains 3 fields that are pulled from a database and displayed on the screen, so no images or anything. Is there any logging or anything that can be turned on to figure out whats going on?

    Thanks,

    Nick

  2. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 10 Feb 2017 Link to this post

    Hello Nick,

    Each report has an error event showing the processing item that is source of the exception.

    in this case, the problem can be related to images loaded in reports or styles. Please test removing images (background images and/or PictureBox items) one by one. Remove in the same way styles, until you detect the one causing the problem.
    Test also to run preview without loading data in reports.


    If you need further help, please post the code for generating the main and sub reports, which will allow us to create local test.

    Regards,
    Stef
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Nick
    Nick avatar
    6 posts
    Member since:
    Feb 2015

    Posted 10 Feb 2017 in reply to Stef Link to this post

    There is no images on the report or the subreport hence my confusion. I dont think there is any code that I can give as the report was fully built using the design tools?

    Nick

  4. Stef
    Admin
    Stef avatar
    3610 posts

    Posted 14 Feb 2017 Link to this post

    Hi Nick,

    If the problem occurs only when the SubReport item is visible, check what report is displayed and its settings. If the sub report visualizes lots of data, or the main report has repeating data, you may have issues in Image preview or web preview in IE browsers.

    The server machine's Event Viewer may contain more details about the error occurring in the custom application.


    In order to provide you more accurate suggestions, we need the reports, the settings for displaying them and information about the amount of data visualized by each report.

    Regards,
    Stef
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top