This is a migrated thread and some comments may be shown as answers.

Report Localization Issue

1 Answer 34 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Mukul
Top achievements
Rank 1
Mukul asked on 16 Jan 2014, 10:46 AM
The reports we are using in our project have a  main report and couple of sub reports embedded within them. The report dll we are using is Version 6.2.12.1017. We are using report viewer for Silverlight for displaying the report.
The default language for the reports are English(US). When a report is loaded in the report viewer for the 1st. time, all the localizations take effect perfectly.

But, if the same report is refreshed or regenerated for some new parameter (not the 1st, time load) it fails to localize properly. In this case (refresh or change in parameter) only the sub reports are displayed with the right language. But the label texts in the main report show up in the default language.

I have checked on the server side where report is generated that the current culture of the thread is correct (not the default English). Yet, the conversion does not take effect in only the main report texts even though the sub reports embedded within it work perfectly.

Our product is already in Beta phase. Hence, we are in urgent need of resolution for this. Hope, you can help us with this.

Regards,

1 Answer, 1 is accepted

Sort by
0
Stef
Telerik team
answered on 20 Jan 2014, 10:11 AM
Hello Mukul,

We verified there is an issue with the localization based on the provided information in your support ticket on the same question.

If you have any further questions, let us continue the discussion in your support ticket.

Regards,
Stef
Telerik

New HTML5/JS REPORT VIEWER with MOBILE AND TOUCH SUPPORT available in Telerik Reporting Q3 2013! Get the new Reporting version from your account or download a trial.

Tags
General Discussions
Asked by
Mukul
Top achievements
Rank 1
Answers by
Stef
Telerik team
Share this question
or