This is a migrated thread and some comments may be shown as answers.

IIS 7.0 + Telerik.ReportViewer.axd

1 Answer 109 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jones
Top achievements
Rank 1
Jones asked on 30 Sep 2009, 04:27 AM
Hi,

I have deployed  my application in IIS7.0 (windows 2008). I am using Telerik Reporting. I have registered the Telerik.ReportViewer.axd  in web.config as follows.

<system.webServer>  
    <validation validateIntegratedModeConfiguration="false"/>  
    ......  
    ......  
    ......  
    <handlers>  
      <remove name="WebServiceHandlerFactory-Integrated"/>  
      <remove name="ScriptHandlerFactory" />  
      <remove name="ScriptHandlerFactoryAppServices" />  
      <remove name="ScriptResource" />  
      <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode"  
           type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>  
      <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode"  
           type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>  
      <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd"  
           type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />  
      
      <add name="Telerik.ReportViewer.axd_*" path="Telerik.ReportViewer.axd" verb="*"  
           type = "Telerik.ReportViewer.WebForms.HttpHandler, Telerik.ReportViewer.WebForms, Version=2.9.9.202, Culture=neutral, PublicKeyToken=a9d7983dfcc261be"  
           preCondition="integratedMode,runtimeversionv2.0" />  


    </handlers>  
  </system.webServer> 

Eventhough it showing the following error.

The http handler needed by the Report Viewer has not beenregistered in the application's web.config file.  Add <add verb="*"path="Telerik.ReportViewer.axd" type ="Telerik.ReportViewer.WebForms.HttpHandler,Telerik.ReportViewer.WebForms, Version=2.9.9.202, Culture=neutral,PublicKeyToken=a9d7983dfcc261be" /> to the system.web/httpHandlerssection of the configuration file.

kindly tell me a solution.

Thanks & Regards,
Jones

1 Answer, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 30 Sep 2009, 09:17 AM
Hello Jones,

The web report viewer is looking for its handler at two places: <system.web>/<httpHandlers>  and <system.webServer>/<handlers>, so make sure you have a handler in the <system.web>/<httpHandlers> section as well. In fact, there is no need to manually add those handlers if you are using the web.config from your dev machine where it worked.
Anyway if you have the handler added to both sections, then the problem is most likely related to your IIS7 configuration. Check if IIS 7 has been properly set up (http://www.trainsignaltraining.com/windows-server-2008-iis7/2008-03-21/) and try reinstalling it if needed . By default it serves only static content and option for serving asp.net pages has to be manually set in the rules. Also it makes a difference whether IIS7 works in integrated or classic pipeline mode. Currently in your handler registration there is an attribute preCondition which is set for integratedMode.

Sincerely yours,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Tags
General Discussions
Asked by
Jones
Top achievements
Rank 1
Answers by
Steve
Telerik team
Share this question
or