Keeping Up to Date

The Kendo UI for Angular packages are released frequently with bug fixes and new features.

Semantic Versioning

The Kendo UI packages for Angular are released independently and their version numbers follow the rules of Semantic Versioning:

  • A Major version bump (X.y.z) signals a breaking change in the API. You might need to update application code or dependencies.
  • A Minor version bump (x.Y.z) signals the addition of new features. Existing code will continue to work but new features may require additional setup.
  • A Patch version bump (x.y.Z) indicates a bug-fix release. Typically, patches do not require changes to application code.

Updating to Compatible Releases

The package.json file references a major version range—for example, "@progress/kendo-angular-grid": "^3.0.0". To fetch the latest compatible Minor or Patch release, run npm update.

Check in the updated package-lock.json file in the source control.

Updating to Latest Versions

To update to the most recent versions of the Kendo UI for Angular components, use npm-check-updates.

Upgrading between major versions might require you to change the application code. For more details, refer to the Changelog of each individual package.

npx ncu -u -f /^@progress/

A successful run will record the updated versions in package.json. The next step is to clean up existing modules and re-install:

npx rimraf package-lock.json node_modules
npm install

Updating Angular

To generate checklists for upgrading between framework versions, use the Angular Upgrade Guide.

Angular 6 is a major release that includes improvements and breaking changes. The latest version of the Kendo UI for Angular components are compatible with Angular 6 and 7, but require special considerations with regard to RxJS. The Kendo UI for Angular packages are built against RxJS 5.5+ to maintain compatibility with previous versions of Angular. To work with RxJS 6.0, install the rxjs-compat package.

npm install --save rxjs-compat@6

A future update, tentatively scheduled for May 2019, will drop the need for installing rxjs-compat. The new versions will not be compatible with Angular 4 and 5.

In this article