All Components

Upgrading to Angular 6

Angular 6 is a major release that includes many improvements and some breaking changes.

The latest version of the Kendo UI for Angular components are compatible with Angular 6. To get your application running with Angular 6, refer to the Angular Update Guide and to the following sections.

Updating the Component Packages

To update to the most recent versions of the Kendo UI for Angular components, use npm-check-updates.

Upgrading between major versions might require you to change your application code. For more details, refer to the Changelog of each individual package.

npm install -g npm-check-updates
ncu -u -f /^@progress/

Updating to RxJS 6.0

Angular 6 ships with the major RxJS version 6 update. RxJS version 6 is not fully backwards-compatible and may require you to change your code. For detailed instructions, refer to the RxJS v5.x to v6 Update Guide.

The Kendo UI for Angular packages are built against RxJS 5.5+ to maintain compatibility with previous versions of Angular. To work with RxJS 6.0, install the rxjs-compat package.

npm install --save rxjs-compat@6
In this article